Bug 110574 - [Progress Events] Interface objects properties should be Configurable.
: [Progress Events] Interface objects properties should be Configurable.
Status: RESOLVED DUPLICATE of bug 110573
: WebKit
WebCore Misc.
: 528+ (Nightly build)
: All Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2013-02-22 01:50 PST by
Modified: 2013-04-17 07:46 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-02-22 01:50:10 PST
Steps to reproduce:

ProgressEvent CR (http://www.w3.org/TR/progress-events/) test
- Test wiki: http://www.w3.org/wiki/Webapps/Interop/ProgressEvents
- Test suite: http://w3c-test.org/webapps/ProgressEvents/tests/
- Test case: http://w3c-test.org/webapps/ProgressEvents/tests/submissions/Ms2ger/interface.html
(7) Interface objects properties should be Configurable


Actual results:

Test case failed: 

delete window.ProgressEvent
does not work.


Expected results:

ProgressEvent is configurable in window object. Hence, the assertions pass by actually delete the ProgressEvent property from window global.
(See 4.4. Interfaces of WebIDL: http://dev.w3.org/2006/webapi/WebIDL/#es-interfaces)
------- Comment #1 From 2013-04-17 07:46:21 PST -------
Will handle this in Bug 110573 as the 2 bugs are strongly related.

*** This bug has been marked as a duplicate of bug 110573 ***