Bug 110470 - [GTK][AC] Animating layer disappears while running with clutter backend
Summary: [GTK][AC] Animating layer disappears while running with clutter backend
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 105699 113318
  Show dependency treegraph
 
Reported: 2013-02-21 07:31 PST by ChangSeok Oh
Modified: 2013-03-29 01:20 PDT (History)
2 users (show)

See Also:


Attachments
Patch (4.30 KB, patch)
2013-02-22 10:24 PST, ChangSeok Oh
gns: review+
gns: commit-queue-
Details | Formatted Diff | Diff
Patch (4.97 KB, patch)
2013-03-28 02:32 PDT, ChangSeok Oh
no flags Details | Formatted Diff | Diff
Patch (5.04 KB, patch)
2013-03-28 03:04 PDT, ChangSeok Oh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ChangSeok Oh 2013-02-21 07:31:16 PST
'Toss' & 'fade through' demo in http://www.apple.com/html5/showcase/transitions/ don't run well.
Nothing is shown while animation.
Comment 1 ChangSeok Oh 2013-02-22 10:24:57 PST
Created attachment 189790 [details]
Patch
Comment 3 Gustavo Noronha (kov) 2013-03-27 10:10:09 PDT
Comment on attachment 189790 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=189790&action=review

I could not reproduce this problem in webkit-clutter. I guess it might be a bad interaction with clutter-gtk. The change makes sense anyway. Please merge this change to webkit-clutter master as well! cq- because of the requested changes.

> Source/WebCore/platform/graphics/clutter/GraphicsLayerClutter.cpp:656
> +        GraphicsLayerClutter* curChild = static_cast<GraphicsLayerClutter*>(childLayers[i]);

Let's take the opportunity to fix the naming here, curChild -> currentChild

> Source/WebCore/platform/graphics/clutter/GraphicsLayerClutter.cpp:658
> +        g_assert(GRAPHICS_LAYER_IS_ACTOR(childLayer));

Make this an ASSERT() instead.
Comment 4 ChangSeok Oh 2013-03-28 02:32:31 PDT
Created attachment 195508 [details]
Patch
Comment 5 ChangSeok Oh 2013-03-28 03:04:44 PDT
Created attachment 195514 [details]
Patch
Comment 6 ChangSeok Oh 2013-03-28 08:31:58 PDT
Comment on attachment 189790 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=189790&action=review

Thank you for the review!

>> Source/WebCore/platform/graphics/clutter/GraphicsLayerClutter.cpp:656
>> +        GraphicsLayerClutter* curChild = static_cast<GraphicsLayerClutter*>(childLayers[i]);
> 
> Let's take the opportunity to fix the naming here, curChild -> currentChild

Done.

>> Source/WebCore/platform/graphics/clutter/GraphicsLayerClutter.cpp:658
>> +        g_assert(GRAPHICS_LAYER_IS_ACTOR(childLayer));
> 
> Make this an ASSERT() instead.

Done.
Comment 7 ChangSeok Oh 2013-03-28 08:33:47 PDT
(In reply to comment #3)
> (From update of attachment 189790 [details])
> Please merge this change to webkit-clutter master as well! cq- because of the requested changes.
Yeap. I'll do immediately after landing this patch!
Comment 8 WebKit Review Bot 2013-03-28 08:58:22 PDT
Comment on attachment 195514 [details]
Patch

Clearing flags on attachment: 195514

Committed r147121: <http://trac.webkit.org/changeset/147121>