Bug 110433 - The DFG backend's and OSR's decision to unbox a variable should be based on whether it's used in a typed context
Summary: The DFG backend's and OSR's decision to unbox a variable should be based on w...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on: 110533 110535 110650 112106
Blocks: 109388
  Show dependency treegraph
 
Reported: 2013-02-20 22:52 PST by Filip Pizlo
Modified: 2013-03-11 23:27 PDT (History)
7 users (show)

See Also:


Attachments
work in progress (12.48 KB, patch)
2013-02-25 11:09 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff
it runs things (16.81 KB, patch)
2013-02-25 17:50 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (19.34 KB, patch)
2013-02-26 16:46 PST, Filip Pizlo
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2013-02-20 22:52:59 PST
I have no evidence that this doesn't work.  I just think we can do better.
Comment 1 Filip Pizlo 2013-02-25 11:09:12 PST
Created attachment 190094 [details]
work in progress
Comment 2 Filip Pizlo 2013-02-25 17:50:38 PST
Created attachment 190167 [details]
it runs things

Haven't seen what the perf impact is, yet.  And I'm not yet sure that it's entirely correct.
Comment 3 Filip Pizlo 2013-02-26 16:46:34 PST
Created attachment 190392 [details]
the patch
Comment 4 Mark Hahnenberg 2013-02-26 17:13:33 PST
Comment on attachment 190392 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=190392&action=review

r=me too, fwiw

> Source/JavaScriptCore/dfg/DFGCommon.h:225
> +bool setAndCheck(T& left, U right)

checkAndSet?
Comment 5 Filip Pizlo 2013-02-26 17:13:54 PST
(In reply to comment #4)
> (From update of attachment 190392 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=190392&action=review
> 
> r=me too, fwiw
> 
> > Source/JavaScriptCore/dfg/DFGCommon.h:225
> > +bool setAndCheck(T& left, U right)
> 
> checkAndSet?

Yup, renamed!
Comment 6 Filip Pizlo 2013-02-26 17:47:33 PST
Landed in http://trac.webkit.org/changeset/144131