Bug 110414 - CMake should not require build target
Summary: CMake should not require build target
Status: RESOLVED DUPLICATE of bug 114243
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-20 17:26 PST by Mark Salisbury
Modified: 2013-11-05 08:51 PST (History)
3 users (show)

See Also:


Attachments
Proposed fix (1.51 KB, patch)
2013-02-20 17:59 PST, Mark Salisbury
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Salisbury 2013-02-20 17:26:06 PST
A bug was introduced recently (IMO) that requires a build target (Debug, Release, RelWithDebInfo, MinSizeRelease) to be specified when invoking CMake.  If you don't specify a build target, you get an error from the top level CMakeLists.txt file on line 10 because it attempts to convert the build type "tolower".

When I run CMake I have it to generate Visual Studio project files, then I open WebKit.sln and build from inside the VS IDE.

The change I'd like to see guarded was introduced in http://trac.webkit.org/changeset/140990.
Comment 1 Mark Salisbury 2013-02-20 17:59:03 PST
Created attachment 189431 [details]
Proposed fix
Comment 2 Mark Salisbury 2013-02-26 09:29:14 PST
Am I alone in seeing this issue as a problem?  Maybe I wasn't clear in describing the issue?
Comment 3 Patrick R. Gansterer 2013-04-06 04:49:16 PDT
Comment on attachment 189431 [details]
Proposed fix

View in context: https://bugs.webkit.org/attachment.cgi?id=189431&action=review

> CMakeLists.txt:12
> -string(TOLOWER ${CMAKE_BUILD_TYPE} CMAKE_BUILD_TYPE)
> +if (CMAKE_BUILD_TYPE)
> +    string(TOLOWER ${CMAKE_BUILD_TYPE} CMAKE_BUILD_TYPE)
> +endif ()

IMHO we should only remove the TOLOWER and replace "debug" with "Debug" in the other CMake files
Comment 4 Patrick R. Gansterer 2013-05-15 02:11:08 PDT
Redolved with https://trac.webkit.org/changeset/147992

*** This bug has been marked as a duplicate of bug 114243 ***
Comment 5 Csaba Osztrogonác 2013-11-05 08:51:11 PST
Comment on attachment 189431 [details]
Proposed fix

Cleared review? from attachment 189431 [details] so that this bug does not appear in http://webkit.org/pending-review.  If you would like this patch reviewed, please attach it to a new bug (or re-open this bug before marking it for review again).