Bug 110374 - Accept 'allowfullscreen' in addition to 'webkitallowfullscreen'.
Summary: Accept 'allowfullscreen' in addition to 'webkitallowfullscreen'.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Vincent Scheib
URL:
Keywords:
: 110400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-20 13:27 PST by Vincent Scheib
Modified: 2013-03-01 02:54 PST (History)
4 users (show)

See Also:


Attachments
Patch (13.37 KB, patch)
2013-02-20 13:36 PST, Vincent Scheib
no flags Details | Formatted Diff | Diff
Patch (14.14 KB, patch)
2013-02-20 13:55 PST, Vincent Scheib
no flags Details | Formatted Diff | Diff
Patch (14.14 KB, patch)
2013-02-20 14:11 PST, Vincent Scheib
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Scheib 2013-02-20 13:27:45 PST
Accept 'allowfullscreen' in addition to 'webkitallowfullscreen'.
Comment 1 Vincent Scheib 2013-02-20 13:36:57 PST
Created attachment 189365 [details]
Patch
Comment 2 Adam Barth 2013-02-20 13:46:16 PST
Comment on attachment 189365 [details]
Patch

Should we use FeatureObserver to see how often sites use the prefixed versus the unprefixed attribute?  (We can do that in a followup patch if you like.)
Comment 3 Vincent Scheib 2013-02-20 13:55:15 PST
Created attachment 189369 [details]
Patch
Comment 4 WebKit Review Bot 2013-02-20 14:07:16 PST
Attachment 189369 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fullscreen/full-screen-enabled-prefixed-expected.txt', u'LayoutTests/fullscreen/full-screen-enabled-prefixed.html', u'LayoutTests/fullscreen/full-screen-enabled.html', u'LayoutTests/fullscreen/full-screen-iframe-allowed-prefixed-expected.txt', u'LayoutTests/fullscreen/full-screen-iframe-allowed-prefixed.html', u'LayoutTests/fullscreen/full-screen-iframe-allowed.html', u'LayoutTests/fullscreen/full-screen-iframe-with-mixed-allow-webkitallow-attribute-expected.txt', u'LayoutTests/fullscreen/full-screen-iframe-with-mixed-allow-webkitallow-attribute.html', u'LayoutTests/fullscreen/resources/full-screen-iframe-with-mixed-allow-webkitallow-iframe1.html', u'LayoutTests/fullscreen/resources/full-screen-iframe-with-mixed-allow-webkitallow-iframe2.html', u'Source/WebCore/ChangeLog', u'Source/WebCore/dom/Document.cpp', u'Source/WebCore/html/HTMLAttributeNames.in']" exit_code: 1
LayoutTests/ChangeLog:21:  Need whitespace between colon and description  [changelog/filechangedescriptionwhitespace] [5]
Total errors found: 1 in 14 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Vincent Scheib 2013-02-20 14:11:17 PST
Created attachment 189373 [details]
Patch
Comment 6 Vincent Scheib 2013-02-20 14:12:17 PST
Thanks.

FeatureObserver requires some thought about when and how to measure it -- e.g. per fullscreenRequest, for each nested iframe, for each iframe parsed, etc. I think it should be thought out and done in a separate patch if we want that data.

Also, please re-flag review bit -- I accidentally dropped it on the follow-up patch upload (had omitted one of the new test expectations).
Comment 7 Vincent Scheib 2013-02-20 16:34:09 PST
Committed r143533: <http://trac.webkit.org/changeset/143533>
Comment 8 Jer Noble 2013-02-20 16:55:39 PST
*** Bug 110400 has been marked as a duplicate of this bug. ***
Comment 9 Jer Noble 2013-02-20 16:56:52 PST
Great minds. ;)
Comment 10 Vincent Scheib 2013-02-20 17:22:14 PST
Ha! ;)
Comment 11 Eric Seidel (no email) 2013-03-01 02:54:54 PST
Comment on attachment 189373 [details]
Patch

Cleared review? from attachment 189373 [details] so that this bug does not appear in http://webkit.org/pending-review.  If you would like this patch reviewed, please attach it to a new bug (or re-open this bug before marking it for review again).