Bug 110358 - Web Inspector: Window shifts when dragging the inspector between displays
Summary: Web Inspector: Window shifts when dragging the inspector between displays
Status: RESOLVED DUPLICATE of bug 146324
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.8
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-02-20 11:03 PST by Matt Yohe
Modified: 2015-06-25 16:00 PDT (History)
4 users (show)

See Also:


Attachments
A zip file that includes two images. One named Works that shows a display configuration that works normally, and one named Broken that does not. (15.00 KB, application/zip)
2013-02-20 11:03 PST, Matt Yohe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Yohe 2013-02-20 11:03:37 PST
Created attachment 189340 [details]
A zip file that includes two images. One named Works that shows a display configuration that works normally, and one named Broken that does not.

When click-dragging the windowed inspector between two displays with the displays in a specific configuration, the window will jump vertically from underneath the cursor. This only appears to occur when the two displays are not top aligned.

Secondly: This does not seem to occur when grabbing a window edge, rather only when dragging from a region in the toolbar, inline with icons.

I've attached two images in a zip file that includes two images. One named Works that shows a display configuration that works as expected, and one named Broken that does not.
Comment 1 Radar WebKit Bug Importer 2013-02-20 12:09:18 PST
<rdar://problem/13255811>
Comment 2 Joseph Pecoraro 2015-06-25 16:00:17 PDT
This should soon be fixed on future Mac OS X versions with the changes in bug 146324. Forward duping to that since that has a patch up!

*** This bug has been marked as a duplicate of bug 146324 ***