Bug 110337 - fast/workers/storage/interrupt-database.html hits assert frequently
Summary: fast/workers/storage/interrupt-database.html hits assert frequently
Status: RESOLVED DUPLICATE of bug 110247
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-20 06:22 PST by Antti Koivisto
Modified: 2013-02-20 06:27 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2013-02-20 06:22:41 PST
for example:

http://build.webkit.org/results/Apple%20MountainLion%20Debug%20WK1%20(Tests)/r143452%20(5665)/results.html
http://build.webkit.org/results/Apple%20MountainLion%20Debug%20WK1%20(Tests)/r143432%20(5656)/results.html

Thread 22 Crashed:: WebCore: Database
0   com.apple.WebCore             	0x000000010ff7db04 WebCore::SQLTransactionStateMachine<WebCore::SQLTransactionBackend>::setStateToRequestedState() + 84 (SQLTransactionStateMachine.h:85)
1   com.apple.WebCore             	0x000000010ff7cbf2 WebCore::SQLTransactionBackend::performNextStep() + 66 (SQLTransactionBackend.cpp:497)
2   com.apple.WebCore             	0x000000010eb7142d WebCore::DatabaseBackendAsync::DatabaseTransactionTask::doPerformTask() + 45 (DatabaseTask.cpp:174)
3   com.apple.WebCore             	0x000000010eb70f44 WebCore::DatabaseTask::performTask() + 180 (DatabaseTask.cpp:91)
4   com.apple.WebCore             	0x000000010eb71c37 WebCore::DatabaseThread::databaseThread() + 199 (DatabaseThread.cpp:112)
5   com.apple.WebCore             	0x000000010eb71afd WebCore::DatabaseThread::databaseThreadStart(void*) + 29 (DatabaseThread.cpp:100)
6   com.apple.JavaScriptCore      	0x000000010d3b3fe0 WTF::threadEntryPoint(void*) + 144 (Threading.cpp:70)
7   com.apple.JavaScriptCore      	0x000000010d3b49d8 WTF::wtfThreadEntryPoint(void*) + 104 (ThreadingPthreads.cpp:196)
8   libsystem_c.dylib             	0x00007fff8e7fd742 _pthread_start + 327
9   libsystem_c.dylib             	0x00007fff8e7ea181 thread_start + 13

template<typename T>
void SQLTransactionStateMachine<T>::setStateToRequestedState()
{
    ASSERT(m_nextState == SQLTransactionState::Idle);
...
Comment 1 Antti Koivisto 2013-02-20 06:27:42 PST
Already filed.

*** This bug has been marked as a duplicate of bug 110247 ***