Add animation related classes for the new calendar picker
Created attachment 188910 [details]
Comment on attachment 188910 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=188910&action=review
> + this.dispatchEvent("animationFrameWillFinish");
If the name "animationFrameWillFinish" is used by other classes, this class should provide a constant symbol for it.
> + */
> + */
> + this.id = Animator.lastId++;
> + this.from = 0;
> + this.to = 0;
> + this._delta = 0;
> + this.duration = 100;
> + this.step = null;
> + this.lastStepTime = null;
> + this.progress = 0.0;
> + this.timingFunction = AnimationTimingFunction.Linear;
Should these members be public? If they should not be updated by other objects, they should be private and should provide accessor functions.
; is not needed.
> + this.dispatchEvent("didAnimationStart");
If the name "didAnimationStart" is used by other classes, this class should provide a constant symbol for it.
> + this.dispatchEvent("didAnimationStop", this);
If the name "didAnimationStop" is used by other classes, this class should provide a constant symbol for it.
> + return this.stop();
confusing code. should be
Created attachment 189491 [details]
Comment on attachment 189491 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=189491&action=review
> + (AnimationTimingFunction.Linear): Parameter t should be a number between 0 and 1.
Such comment should be in the code, or the code should have console.assert.
> +Animator.lastId = 0;
I guess this should be private.
Created attachment 189516 [details]
Comment on attachment 189516 [details]
Clearing flags on attachment: 189516
Committed r143598: <http://trac.webkit.org/changeset/143598>
All reviewed patches have been landed. Closing bug.