There's no reason for Element::updateStyleAttribute() and Element::updateAnimatedSVGAttribute() to be virtual.
Created attachment 188731 [details]
Comment on attachment 188731 [details]
Not sure it’s ideal to have “synchronize attribute” as the name for both the smart function and the one that should only be called if the attribute is known dirty. I guess I am the one who told you to remove “if needed”, and I still stand by that.
Committed r143114: <http://trac.webkit.org/changeset/143114>