Bug 10995 - REGRESSION: Clicking with mouse on a link or any text in any page changes the mouse pointer to the arrow, if Flash is running in any window
Summary: REGRESSION: Clicking with mouse on a link or any text in any page changes the...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://macworld.idg.se/ArticlePages/2...
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2006-09-23 02:46 PDT by jonathanjohnsson
Modified: 2007-02-07 05:03 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonathanjohnsson 2006-09-23 02:46:13 PDT
Clicking within a text field, password field or text area, changes the pointer shape of the mouse from "text insertion" to the plain arrow. This isn't expected, makes it harder to select text, and doesn't happen in released Safari. This is with a less than one day old WebKit.
Comment 1 jonathanjohnsson 2006-09-23 14:08:15 PDT
I can't see the bug always, but once it happens, it seems to keep on happening until I quit WebKit. I will try to find what triggers it.
Comment 2 jonathanjohnsson 2006-09-23 14:23:05 PDT
Once you go to the following page and keep it open (that is, not minimized or in a background tab), all text fields/areas show the bug as described above, including those in other windows and tabs.

http://macworld.idg.se/ArticlePages/200609/23/20060923191733_MW/20060923191733_MW.dbp.asp

I first thought it was some Flash issue, but I can't find any such things on that page on a first look.
Comment 3 jonathanjohnsson 2006-09-23 14:44:26 PDT
mitzpettel noted that clicking in any normal, uneditable, text also shows the changing pointer bug, so the issue isn't confined to forms. 

Also, disabling Javascript makes the bug go away.
Comment 4 jonathanjohnsson 2006-09-23 14:49:11 PDT
Also clicking any link, even an image, makes the mouse pointer go from "hand" to "pointer". Changing bug info to reflect findings. 
Comment 5 jonathanjohnsson 2006-09-24 00:10:20 PDT
Firefox behaves almost exactly the same as WebKit, changing mouse pointer on click. Still, I don't think a page in one window should be able to affect the behaviour in another window.
Comment 6 jonathanjohnsson 2006-09-24 00:42:10 PDT
Ok, so it *was* a Flash issue (I have Flash 9), which would probably explain why Firefox behaves the same. Keeping only the object tag in the mentioned url shows the bug.

Also, only the behaviour when clicking in form fields seems to be a regression, and this is where you notice it the most, selecting text and such. Clicking on normal text behaves the same in released Safari as in WebKit.

Maybe I will try cutting into the object tag parameters and stuff to see what triggers the bug, but I feel this would happen anytime the Flash player is just running. Checking some other pages with Flash content, the same bug appears.

It would be nice if someone could create a minimal Flash thing to see if it's just the player being loaded that triggers the bug, or if the flash contents need to use some feature for it to appear.
Comment 7 Stephanie Lewis 2006-11-06 21:51:52 PST
radar 4823139
Comment 8 Maciej Stachowiak 2007-02-07 05:03:03 PST
bugs in the Flash plugin don't belong here, but this is still being tracked in Radar.