Bug 109885 - [WK2] Rename from scrollOffset to scrollDelta in WebChromeClient.
Summary: [WK2] Rename from scrollOffset to scrollDelta in WebChromeClient.
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dongseong Hwang
Depends on:
Reported: 2013-02-14 21:04 PST by Dongseong Hwang
Modified: 2013-02-14 23:16 PST (History)
4 users (show)

See Also:

Patch (17.06 KB, patch)
2013-02-14 21:07 PST, Dongseong Hwang
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dongseong Hwang 2013-02-14 21:04:46 PST
Chrome sends a scroll delta to WebChromeClient but WebChromeClient names it
scrollOffset. So this patch corrects this misnaming.

In addition, all subclasses of LayerTreeHost don't use the misnamed
scrollOffset in scrollNonCompositedContents(), so this patch removes the
scrollOffset argument.
Comment 1 Dongseong Hwang 2013-02-14 21:07:01 PST
Created attachment 188475 [details]
Comment 2 WebKit Review Bot 2013-02-14 23:16:42 PST
Comment on attachment 188475 [details]

Clearing flags on attachment: 188475

Committed r142968: <http://trac.webkit.org/changeset/142968>
Comment 3 WebKit Review Bot 2013-02-14 23:16:45 PST
All reviewed patches have been landed.  Closing bug.