Bug 10965 - Layout tests need a way to specify a need for a clean session history
Summary: Layout tests need a way to specify a need for a clean session history
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://build.webkit.org/results/post-...
Keywords:
: 10926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-21 01:14 PDT by Adam Roben (:aroben)
Modified: 2010-08-09 16:16 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2006-09-21 01:14:59 PDT
As reported in bug 10958, fast/js/window-properties.html will fail when run with all the other layout tests, but running it by itself or running all of fast/js will show it passing. This is causing the failures on the buildbot.
Comment 1 Adam Roben (:aroben) 2006-09-21 01:20:52 PDT
*** Bug 10926 has been marked as a duplicate of this bug. ***
Comment 2 Adam Roben (:aroben) 2006-09-29 03:25:22 PDT
The failure seems to be caused by DumpRenderTree opening every test in the same WebView, thereby building up a session history. We need tests to be able to specify that they need a clean session.
Comment 3 Adam Roben (:aroben) 2006-10-02 14:08:03 PDT
r16720 fixes the checked-in results to match what you get when you do a full LayoutTests run. However, we still need a way for tests to specify they need a clean history.
Comment 4 Mihai Parparita 2010-08-09 16:16:54 PDT
layoutTestController.clearBackForwardList  got added a long time ago (http://trac.webkit.org/changeset/25515, if not earlier).