Bug 109294 - Web Inspector: Timeline: invalidate and force locations are same for Layout records caused by style recalculaiton
Summary: Web Inspector: Timeline: invalidate and force locations are same for Layout r...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Andrey Kosyakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 06:07 PST by Andrey Kosyakov
Modified: 2013-02-11 10:17 PST (History)
10 users (show)

See Also:


Attachments
Patch (3.31 KB, patch)
2013-02-08 06:15 PST, Andrey Kosyakov
no flags Details | Formatted Diff | Diff
Patch (8.37 KB, patch)
2013-02-11 05:42 PST, Andrey Kosyakov
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Kosyakov 2013-02-08 06:07:19 PST
When script requests a layout-dependent property, we may invoke both style recalculation and relayout. In case where layout was invalidated by style recalculation, we would report the stack that causes the layout as the one that invalidated it. This may be confusing, so let's report the cause of style recalculation instead.
Comment 1 Andrey Kosyakov 2013-02-08 06:15:19 PST
Created attachment 187304 [details]
Patch
Comment 2 Pavel Feldman 2013-02-09 01:20:37 PST
Comment on attachment 187304 [details]
Patch

A test? Otherwise looks good.
Comment 3 Andrey Kosyakov 2013-02-11 05:42:22 PST
Created attachment 187552 [details]
Patch
Comment 4 Andrey Kosyakov 2013-02-11 10:17:49 PST
Committed r142488: <http://trac.webkit.org/changeset/142488>