Add comments in build-webkit usage for the following command line switches: —sdk=<sdk> —debug —release —device —simulator We should remove switches for —devel and —deploy when determining the Xcode configuration while we are at it.
Created attachment 187159 [details] Patch
Comment on attachment 187159 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=187159&action=review r=me with those changes. > Tools/Scripts/build-webkit:112 > - --debug Compile in debug mode > + --debug Compile with Debug Xcode configuration > + --release Compile with Release Xcode configuration The --debug (and --release) switches are used by more than just platforms that build with Xcode. I would suggest removing "Xcode" from the help text here. > Tools/Scripts/build-webkit:113 > + --sdk=<sdk> Use a specific Xcode SDK I would add "(iOS and Mac only)" to the end of the description here. > Tools/Scripts/build-webkit:115 > + --device Use the iphoneos.internal SDK > + --simulator Use the iphonesimulator SDK Similarly, add "(iOS only)" here. Maybe: Use the current <sdkname> SDK (iOS only)
Created attachment 187377 [details] Patch Patch updated with the above suggestions.
Comment on attachment 187377 [details] Patch r=me
Comment on attachment 187377 [details] Patch Clearing flags on attachment: 187377 Committed r142373: <http://trac.webkit.org/changeset/142373>
All reviewed patches have been landed. Closing bug.