Bug 10922 - Finger cursor doesn't appear for graphic links adjacent to flash media
Summary: Finger cursor doesn't appear for graphic links adjacent to flash media
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh PowerPC OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.bizadvocates.com/
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-18 15:17 PDT by Kevin M. Dean
Modified: 2010-03-25 11:17 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2006-09-18 15:17:38 PDT
The site linked is an in-progress test site, so if other things get funky, just ignore them.

The issue can be seen when you place your mouse over the white flash movie on the right and then move the cursor over the "Preferred Club Members Register Online" button below it. The cursor doesn't change to a finger properly. It does if you come in from the right or bottom, but not from the left or top which are both flash media.

This doesn't work in the release version of Safari either.
Comment 1 Mark Rowe (bdash) 2006-12-05 20:13:46 PST
Confirmed in both WebKit 418.9.1 and ToT.
Comment 2 Robert Blaut 2008-02-21 22:44:10 PST
The URL doesn't work any more so I'm unable to test if the bug is still valid. Kevin, could you update URL or attach test case for this bug?
Comment 3 Kevin M. Dean 2008-02-22 06:22:45 PST
I've revised the the link to http://development.rhubarbproductions.com/famd/
Comment 4 Alexey Proskuryakov 2010-03-25 09:43:54 PDT
The URL doesn't work any more. There were many changes to cursor handling in plug-ins recently.
Comment 5 Kevin M. Dean 2010-03-25 10:46:02 PDT
I've changed the url to another similar site where flash is directly adjacent to a link. In this case there's a large flash element with buttons directly to the left.

The original issue of this bug seems to be resolved where the cursor doesn't change to a finger if you enter the button from over top flash. Now it works better with a slight difference. If I move slowly, the first pixel entered that triggers the graphic rollover does not change the mouse to a finger, but once moved on to a second pixel in the finger appears. It seems that it has to leave the flash and then progress 1 pixel further before changing.

In my opinion this is no longer really an issue so if someone wants to close this bug, I'm fine with that, but I'll leave it open for now in case someone still sees it as an issue worth looking into.
Comment 6 Alexey Proskuryakov 2010-03-25 11:17:16 PDT
It's probably something like bug 14344 or bug 32123. I also think we can close this.