Bug 10913 - SVG charts from plotkit fail to render unless you scroll them offscreen
Summary: SVG charts from plotkit fail to render unless you scroll them offscreen
Status: RESOLVED DUPLICATE of bug 11984
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://media.liquidx.net/js/plotkit-t...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2006-09-18 03:11 PDT by Gregory Block
Modified: 2007-01-08 16:40 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregory Block 2006-09-18 03:11:19 PDT
In the provided example are a number of charts; by scrolling down and then back up, the ones that are ofscreen render correctly, but the ones that were a part of the document load fail.

This may be related to the way that SVG nodes are added to the document by plotkit - the JS actually adds the SVG node itself along with child contents.

Would be nice to have this work.  :)
Comment 1 Eric Seidel (no email) 2006-09-19 03:04:17 PDT
One of many many invalidation issues in our current SVG support.

It would be nice to reduce this down to a much simpler test case.  I'm not even sure what sort of SVG elements PlotKit is creating here w/o looking more at the code.
Comment 2 Gregory Block 2006-09-21 00:22:28 PDT
what's really odd about it is that it's the first one on the page that renders completely; scroll anywhere, and reload, and the first svg block is fine.  All of the other SVG blocks don't render.
Comment 3 Eric Seidel (no email) 2007-01-08 16:40:22 PST
Fixed by bug 11984.

*** This bug has been marked as a duplicate of 11984 ***