Bug 109039 - [V8] Rename isolated() to getWorld(), rename worldForEnteredContextIfIsolated() to worldForEnteredContext()
Summary: [V8] Rename isolated() to getWorld(), rename worldForEnteredContextIfIsolated...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 03:54 PST by Kentaro Hara
Modified: 2013-02-27 07:33 PST (History)
6 users (show)

See Also:


Attachments
Patch (8.97 KB, patch)
2013-02-06 03:56 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff
patch for landing (9.72 KB, patch)
2013-02-07 00:46 PST, Kentaro Hara
haraken: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2013-02-06 03:54:27 PST
For naming consistency, rename isolated() to getWorld() and rename worldForEnteredContextIfIsolated() to worldForEnteredContext().
Comment 1 Kentaro Hara 2013-02-06 03:56:57 PST
Created attachment 186816 [details]
Patch
Comment 2 WebKit Review Bot 2013-02-06 05:39:10 PST
Comment on attachment 186816 [details]
Patch

Attachment 186816 [details] did not pass cr-linux-debug-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/16388281
Comment 3 Adam Barth 2013-02-06 10:26:20 PST
Comment on attachment 186816 [details]
Patch

Looks like the cr-linux-debug bot is unhappy with this patch.
Comment 4 Kentaro Hara 2013-02-07 00:46:29 PST
Created attachment 187009 [details]
patch for landing
Comment 5 Kentaro Hara 2013-02-07 05:40:20 PST
Comment on attachment 187009 [details]
patch for landing

A patch which this patch depends on was rolled out.
Comment 6 Kentaro Hara 2013-02-10 20:16:37 PST
Committed r142424: <http://trac.webkit.org/changeset/142424>
Comment 7 Dan Carney 2013-02-27 03:55:38 PST
This change makes no sense.  The function on DOMWrapperWorld only returns an isolated world.  It does that for performance.  This leads to semantic ambiguity like in V8GCController::minorGCPrologue:

        DOMWrapperWorld* world = worldForEnteredContextWithoutContextCheck();
        if (world && world->isMainWorld()) {

the branch will never be taken and minor gc is disabled because of this.

Please consider this reverting this renaming.
Comment 8 Kentaro Hara 2013-02-27 07:33:56 PST
ah... This was a big mistake. Let me revert them.

Because we're limiting the number of nodes handled by each minor GC to 10000, I couldn't detect the performance regression by Dromaeo/dom-modify...