Bug 10894 - CSS "size" property is not supported
: CSS "size" property is not supported
Status: RESOLVED WORKSFORME
: WebKit
CSS
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To:
: http://www.peepo.com
:
:
:
  Show dependency treegraph
 
Reported: 2006-09-17 01:21 PST by
Modified: 2011-06-28 15:49 PST (History)


Attachments
print (605 bytes, text/html)
2006-09-17 01:22 PST, jay
no flags Details
CSS test for printing landscape (567 bytes, text/html)
2006-12-15 02:07 PST, jay
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-09-17 01:21:47 PST
this page and the reduced file in attachment should print in landscape format, 

in fact they print in portrait
------- Comment #1 From 2006-09-17 01:22:23 PST -------
Created an attachment (id=10597) [details]
print
------- Comment #2 From 2006-12-05 19:51:36 PST -------
Your reduction is incorrect -- it has CSS rules inside a <script> tag:

<style type="text/css">

</style>

<script type="text/ecmascript" ><!--
@page {size: landscape}
//--></script>


A glance at the code shows that support for the "size" property isn't implemented, which is why your example fails to work as intended.
------- Comment #3 From 2006-12-15 02:07:10 PST -------
Created an attachment (id=11855) [details]
CSS test for printing landscape
------- Comment #4 From 2006-12-15 02:09:12 PST -------
updated patch in response to #2 cheers
------- Comment #5 From 2011-06-28 15:49:46 PST -------
Re-filed as bug 63575.