Bug 108925 - REGRESSION (r141695): http/tests/media/video-play-stall.html is timing out
Summary: REGRESSION (r141695): http/tests/media/video-play-stall.html is timing out
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2013-02-05 01:59 PST by Zan Dobersek
Modified: 2015-02-17 08:50 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2013-02-05 01:59:59 PST
The http/tests/media/video-play-stall.html layout test started timing out intermittently after r141695. When the test doesn't time out, it takes 30 seconds to fail (which is the expected outcome of the test).
http://trac.webkit.org/changeset/141695

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20webkit.org&tests=http%2Ftests%2Fmedia%2Fvideo-play-stall.html
Comment 1 Philippe Normand 2013-02-05 02:19:55 PST
I guess somehow the url is wrongly set, that could explain the timeout. I'm a bit busy now, maybe later today I'll find time to debug this.
Comment 2 Manuel Rego Casasnovas 2013-02-07 08:49:54 PST
I've been taking a look to the issue and I can confirm that with r141695 and r141697 (even without it) the test timeouts instead of simply fail. And without r141695 the test simply fails but id doesn't timeout.

The URL seems to be properly set to:
http://127.0.0.1:8000/resources/load-and-stall.cgi?name=../../../media/content/test.mp4&mimeType=video/mp4&stallAt=100000&stallFor=6

At least at the end of WebKitWebSourceGStreamer::webKitWebSrcSetUri the URL is right.

At the end of MediaPlayerPrivateGStreamer::setPlaybinURL the URL has "webkit+" prefix, but it seems the expected value.

Sorry, but I can't help too much here :-(
Comment 3 Philippe Normand 2013-02-08 03:21:20 PST
This patch breaks HTTP on-disk buffering. I think part of the issue is in GStreamer's uridecodebin which checks the decoder uri instead of querying the uri to the source element.
Comment 4 Philippe Normand 2013-02-08 03:23:09 PST
Closing as bug 108088 was reopened.
Comment 5 Marcos Chavarría Teijeiro (irc: chavaone) 2015-02-17 08:50:41 PST
The test is failing after r179220 (http://trac.webkit.org/changeset/179220)

the diff is the following:

--- /home/ch01/wk-tools/layout-test-results/http/tests/media/video-play-stall-expected.txt
+++ /home/ch01/wk-tools/layout-test-results/http/tests/media/video-play-stall-actual.txt
@@ -4,11 +4,9 @@
 EVENT(durationchange)
 EVENT(loadedmetadata)
 EVENT(loadeddata)
-EVENT(canplay)
-RUN(video.play())
 EVENT(stalled)
-EXPECTED (video.currentTime != '0') OK
+EXPECTED (video.currentTime != '0'), OBSERVED '0' FAIL
 EXPECTED (video.playbackRate === '1') OK
-EXPECTED (video.paused === 'false') OK
+EXPECTED (video.paused === 'false'), OBSERVED 'true' FAIL
 END OF TEST

TestExpectations file updated:

webkit.org/b/108925 http/tests/media/video-play-stall.html [ Failure Timeout ]