Bug 108740 - [chromium] Cannot click in any tab when WebHelperPlugin is in use on Chrome OS R26
Summary: [chromium] Cannot click in any tab when WebHelperPlugin is in use on Chrome O...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: David Dorwin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-01 19:36 PST by David Dorwin
Modified: 2013-02-03 20:05 PST (History)
2 users (show)

See Also:


Attachments
Patch (2.12 KB, patch)
2013-02-01 19:40 PST, David Dorwin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Dorwin 2013-02-01 19:36:00 PST
[chromium] Cannot click in any tab when WebHelperPlugin is in use on Chrome OS R26
Comment 1 David Dorwin 2013-02-01 19:37:56 PST
To reproduce, do something that uses the WebHelperPlugin on Chrome OS R26. Until the WebHelperPlugin is destroyed, you will not be able to click anywhere. The mouse still moves, the keyboard still works, and clicking resumes when the WebHelperPlugin is closed.

The problem is not that the hidden frame is in front of the main page. I verified this by making it visible and small. This is not a problem on Linux or R25.

Removing the following call fixes the problem and does not affect the behavior of the WebHelperPlugin.
    m_widgetClient->show(WebNavigationPolicy());
Comment 2 David Dorwin 2013-02-01 19:40:06 PST
Created attachment 186206 [details]
Patch
Comment 3 Kent Tamura 2013-02-03 15:44:59 PST
Comment on attachment 186206 [details]
Patch

ok
Comment 4 WebKit Review Bot 2013-02-03 20:05:46 PST
Comment on attachment 186206 [details]
Patch

Clearing flags on attachment: 186206

Committed r141731: <http://trac.webkit.org/changeset/141731>
Comment 5 WebKit Review Bot 2013-02-03 20:05:50 PST
All reviewed patches have been landed.  Closing bug.