Bug 108626 - [Qt]REGRESSION(r141136): It made tst_QWebFrame API tests fail
Summary: [Qt]REGRESSION(r141136): It made tst_QWebFrame API tests fail
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 116092 (view as bug list)
Depends on: 105667
Blocks: 38654
  Show dependency treegraph
 
Reported: 2013-02-01 06:01 PST by Ádám Kallai
Modified: 2013-05-15 23:28 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ádám Kallai 2013-02-01 06:01:52 PST
tst_QWebFrame assert after r141136.

FAIL!  : tst_QWebFrame::setUrlHistory() Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (url): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1278)]
FAIL!  : tst_QWebFrame::setUrlUsingStateObject() Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (url): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1324)]
PASS   : tst_QWebFrame::setUrlSameUrl()
FAIL!  : tst_QWebFrame::setUrlThenLoads(resource file) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (url): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1418)]
FAIL!  : tst_QWebFrame::setUrlThenLoads(base specified in HTML) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlToLoad2): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1451)]
PASS   : tst_QWebFrame::loadFinishedAfterNotFoundError()
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call load() in loadStarted() after valid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call load() in loadStarted() after invalid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call load() in loadFinished() after valid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call load() in loadFinished() after invalid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call load() in provisionalLoad() after valid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call load() in provisionalLoad() after invalid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call setUrl() in loadStarted() after valid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call setUrl() in loadStarted() after invalid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call setUrl() in loadFinished() after valid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call setUrl() in loadFinished() after invalid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call setUrl() in provisionalLoad() after valid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
FAIL!  : tst_QWebFrame::loadInSignalHandlers(call setUrl() in provisionalLoad() after invalid url) Compared values are not the same
   Actual   (frame->url()): qrc:/test2.html
   Expected (urlForSetter): qrc:/test1.html
   Loc: [/home/webkitbuildbot/slaves/debug64bit/buildslave/qt-linux-64-debug/build/Source/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1561)]
PASS   : tst_QWebFrame::cleanupTestCase()
Comment 1 Adam Barth 2013-02-01 11:08:03 PST
It's likely because the unit tests assume that WebCore isn't caching resources.  One approach is for the unit tests to disable caching or to clear the memory cache as needed.
Comment 2 Csaba Osztrogonác 2013-05-15 23:27:29 PDT
*** Bug 116092 has been marked as a duplicate of this bug. ***
Comment 3 Csaba Osztrogonác 2013-05-15 23:28:15 PDT
Something changed near caching and this bug isn't valid anymore aftert http://trac.webkit.org/changeset/150169