Bug 108582 - REGRESSION(r111639): delayed animation start can be postponed
Summary: REGRESSION(r111639): delayed animation start can be postponed
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: dstockwell
URL:
Keywords:
Depends on:
Blocks: 107521
  Show dependency treegraph
 
Reported: 2013-01-31 22:20 PST by dstockwell
Modified: 2013-03-06 09:17 PST (History)
5 users (show)

See Also:


Attachments
Patch (6.98 KB, patch)
2013-01-31 22:37 PST, dstockwell
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description dstockwell 2013-01-31 22:20:42 PST
REGRESSION(r111639): delayed animation start can be postponed
Comment 1 dstockwell 2013-01-31 22:37:29 PST
Created attachment 185948 [details]
Patch
Comment 2 WebKit Review Bot 2013-02-01 00:15:47 PST
Comment on attachment 185948 [details]
Patch

Attachment 185948 [details] did not pass cr-linux-debug-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/16302453
Comment 3 Alan Cutter 2013-02-01 02:45:24 PST
(In reply to comment #2)
> (From update of attachment 185948 [details])
> Attachment 185948 [details] did not pass cr-linux-debug-ews (chromium-xvfb):
> Output: http://queues.webkit.org/results/16302453

This reported failure was due to this change in the cr-linux-debug-ews bots: bug 108512
Comment 4 dstockwell 2013-02-01 02:45:58 PST
Comment on attachment 185948 [details]
Patch

cr-linux-debug failure is spurious
Comment 5 Darin Adler 2013-03-06 09:09:53 PST
Comment on attachment 185948 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=185948&action=review

> Source/WebCore/page/animation/AnimationController.cpp:129
> +    if (m_animationTimer.isActive() && (m_animationTimer.repeatInterval() || m_animationTimer.nextFireInterval() <= timeToNextService))
> +        return;

The use of repeat interval in this class is peculiar. I don’t understand the comment at all. It says “to reduce the overhead of starting”.
Comment 6 WebKit Review Bot 2013-03-06 09:17:01 PST
Comment on attachment 185948 [details]
Patch

Clearing flags on attachment: 185948

Committed r144935: <http://trac.webkit.org/changeset/144935>
Comment 7 WebKit Review Bot 2013-03-06 09:17:05 PST
All reviewed patches have been landed.  Closing bug.