Bug 108472 - [Qt] Make it possible to compile WebKit2 Qt related files without access to internal WK2 C++ API
Summary: [Qt] Make it possible to compile WebKit2 Qt related files without access to i...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Hausmann
URL:
Keywords:
Depends on:
Blocks: 108471
  Show dependency treegraph
 
Reported: 2013-01-31 05:57 PST by Simon Hausmann
Modified: 2013-01-31 23:03 PST (History)
7 users (show)

See Also:


Attachments
Patch (10.03 KB, patch)
2013-01-31 07:56 PST, Simon Hausmann
kling: review+
webkit-ews: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Hausmann 2013-01-31 05:57:04 PST
The intent of this task is to create a new static library as part of the Qt port build process that only has WebKit2/UIProcess/API/C in the include search path.

The only other API use allowed outside of this would be the inclusion of UIProecss/API/qt/WKView.h.

This helps to ensure a cleaner separation and avoids the accidental introduction of further layer violations.
Comment 1 Simon Hausmann 2013-01-31 07:56:19 PST
Created attachment 185785 [details]
Patch
Comment 2 Early Warning System Bot 2013-01-31 08:07:54 PST
Comment on attachment 185785 [details]
Patch

Attachment 185785 [details] did not pass qt-wk2-ews (qt):
Output: http://queues.webkit.org/results/16272237
Comment 3 Simon Hausmann 2013-01-31 10:13:58 PST
Committed r141430: <http://trac.webkit.org/changeset/141430>
Comment 4 Csaba Osztrogonác 2013-01-31 22:36:57 PST
(In reply to comment #3)
> Committed r141430: <http://trac.webkit.org/changeset/141430>

CONFIG+=buildbot builds (all Qt-WK2 buildbot and the EWS) are 
still broken because of this change as the EWS reported it.
Comment 5 Simon Hausmann 2013-01-31 22:44:38 PST
(In reply to comment #4)
> (In reply to comment #3)
> > Committed r141430: <http://trac.webkit.org/changeset/141430>
> 
> CONFIG+=buildbot builds (all Qt-WK2 buildbot and the EWS) are 
> still broken because of this change as the EWS reported it.

Yeah, and I was able to reproduce it on my workstation. http://trac.webkit.org/changeset/141467 was supposed to fix it, but strangely the bots didn't do a clean build despite touching a .prf file (and a clean build is required to remove the stale .prl files)

Can you trigger a clean build manually?
Comment 6 Csaba Osztrogonác 2013-01-31 23:03:00 PST
Good point. I thought after the pr* clean build was triggered, but it wasn't.
I checked it. The reason is that diff is generated between the latest success
build and the actual build to determine if a pr* file is changed or not.
But now there wasn't any success build in the history, because we triggered
clean build after r141430.

I triggered a clean build again, and it seems it works now. (But there are
zillion crashes after Apple's last night work.)