Bug 108318 - [Qt] Fix Qt/Mac build after r141024 and r141037
Summary: [Qt] Fix Qt/Mac build after r141024 and r141037
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zeno Albisser
URL:
Keywords:
: 108321 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-30 02:45 PST by Zeno Albisser
Modified: 2013-01-30 06:50 PST (History)
5 users (show)

See Also:


Attachments
Patch (3.14 KB, patch)
2013-01-30 02:50 PST, Zeno Albisser
no flags Details | Formatted Diff | Diff
Patch (3.68 KB, patch)
2013-01-30 05:09 PST, Zeno Albisser
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zeno Albisser 2013-01-30 02:45:56 PST
[Qt] Fix Qt/Mac build after r141024
Comment 1 Zeno Albisser 2013-01-30 02:50:18 PST
Created attachment 185450 [details]
Patch
Comment 2 Kentaro Hara 2013-01-30 03:48:55 PST
Comment on attachment 185450 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=185450&action=review

rs=me

> Source/WTF/ChangeLog:3
> +        [Qt] Fix Qt/Mac build after r141024

I think this error would be due to r141037.
Comment 3 Zeno Albisser 2013-01-30 04:42:07 PST
*** Bug 108321 has been marked as a duplicate of this bug. ***
Comment 4 Zeno Albisser 2013-01-30 05:00:34 PST
Comment on attachment 185450 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=185450&action=review

>> Source/WTF/ChangeLog:3
>> +        [Qt] Fix Qt/Mac build after r141024
> 
> I think this error would be due to r141037.

It is failing on the bot since r141024. But it is likely that the patch fixes more than a "single" breakage. So I'll update the title to mention both revisions.
I will have to re-upload the patch again, because there are two more PLATFORM(MAC) that need to be replaced with OS(DARWIN) in Functional.h. - Sorry for the inconvenience.
Comment 5 Zeno Albisser 2013-01-30 05:09:53 PST
Created attachment 185471 [details]
Patch
Comment 6 Kentaro Hara 2013-01-30 05:10:27 PST
Comment on attachment 185471 [details]
Patch

rs=me
Comment 7 Zeno Albisser 2013-01-30 06:50:28 PST
Comment on attachment 185471 [details]
Patch

Clearing flags on attachment: 185471

Committed r141263: <http://trac.webkit.org/changeset/141263>
Comment 8 Zeno Albisser 2013-01-30 06:50:33 PST
All reviewed patches have been landed.  Closing bug.