The DatabaseManager is a singleton class. Instead of DatabaseManager::manager().isAvailable(), we should be able to call DatabaseManager::isAvailable() instead. The latter form is a little shorter and easier to read. This patch does a small refactor to make this change.
Created attachment 185139 [details]
This patch is mostly cosmetic. I basically moved the DatabaseManager implementation to an Internal class, and reimplemented DatabaseManager methods as static which forwards the call to the Internal instance.
This patch was rs= Sam Weinig.
Comment on attachment 185139 [details]
Attachment 185139 [details] did not pass win-ews (win):
This turned out to be harder than I originally thought. The Windows port does not think that DatabaseManager's "friend"-ship extends to DatabaseManager::Internal.
Since, this effort is turning hairy (it was supposed to be a slam dunk), I'll postpone it. The implementation of DatabaseManager will shift in the near future. I might be able to make this change with minimal effort then. I'll leave it be for now.