Bug 108068 - Web Inspector: [Regression] Search all sources should not search across service projects.
Summary: Web Inspector: [Regression] Search all sources should not search across servi...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Vsevolod Vlasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-28 02:01 PST by Vsevolod Vlasov
Modified: 2013-01-28 23:51 PST (History)
10 users (show)

See Also:


Attachments
Patch (2.36 KB, patch)
2013-01-28 04:18 PST, Vsevolod Vlasov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vsevolod Vlasov 2013-01-28 02:01:00 PST
Patch to follow.
Comment 1 Vsevolod Vlasov 2013-01-28 04:18:26 PST
Created attachment 184969 [details]
Patch
Comment 2 WebKit Review Bot 2013-01-28 04:49:14 PST
Comment on attachment 184969 [details]
Patch

Clearing flags on attachment: 184969

Committed r140966: <http://trac.webkit.org/changeset/140966>
Comment 3 WebKit Review Bot 2013-01-28 04:49:18 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 johnjbarton 2013-01-28 14:49:59 PST
Global "Search sources" is broken, I guess we don't have test coverage for it?

> Source/WebCore/inspector/front-end/ScriptsSearchScope.js:126
> +            uiSourceCodes = this._uiSourceCodes.concat(projects[i].uiSourceCodes());

I guess you meant
   uiSourceCodes = uiSourceCodes.concat(projects[i].uiSourceCodes());
since there is no this._uiSourceCodes
Comment 5 Vsevolod Vlasov 2013-01-28 23:51:14 PST
I'll fix it and add a test in https://bugs.webkit.org/show_bug.cgi?id=108157.