Bug 108048 - storage/indexeddb tests are crashing
Summary: storage/indexeddb tests are crashing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Joshua Bell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 21:20 PST by Keishi Hattori
Modified: 2013-01-28 14:22 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keishi Hattori 2013-01-27 21:20:57 PST
I rolled out r140602 but it still keeps crashing and I can't figure it out. I am going to mark them as crashing.
Comment 2 Joshua Bell 2013-01-28 12:03:46 PST
This is the suspect change in the range that introduced the crash on all the bots:

http://trac.webkit.org/changeset/140653

Which is a revert of: 

http://trac.webkit.org/changeset/140783

But this dependent(?) Chromium change wasn't reverted...

http://src.chromium.org/viewvc/chrome?view=rev&revision=178734

Unfortunately, it's not reproducing for me at the moment. :P Maybe a WebKit/chromium/DEPS roll is involved? I'll keep plugging away at it.
Comment 3 Adam Barth 2013-01-28 12:07:59 PST
Ah!  Sorry for causing a mess.
Comment 4 Joshua Bell 2013-01-28 12:09:13 PST
(In reply to comment #3)
> Ah!  Sorry for causing a mess.

My comment was poorly phrased. I don't have proof that's the cause, just a hunch.

"This is *a* suspect change..."

Still can't repro locally, which is itself odd. Alas, alec (who could) is out today.
Comment 5 Joshua Bell 2013-01-28 12:12:08 PST
Also, looks like WebKit/chromium/DEPS is at 178434 which is prior to the Chromium rev. The test crashes are also only happening on the ToT bots, not the DEPS bots.
Comment 6 Joshua Bell 2013-01-28 12:22:45 PST
My environment must have been mucked up. Reproducing easily now.

Reverting http://src.chromium.org/viewvc/chrome?view=rev&revision=178734 makes the crashes go away reliably as suspected. I'll revert that over on the chromium side.