Bug 10804 - symbol styles not inherited
Summary: symbol styles not inherited
Status: RESOLVED DUPLICATE of bug 12125
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.peepo.co.uk
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-10 14:14 PDT by jay
Modified: 2007-01-06 14:43 PST (History)
0 users

See Also:


Attachments
demonstration of stroke being set, but not inherited (400 bytes, image/svg+xml)
2006-09-10 14:15 PDT, jay
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2006-09-10 14:14:49 PDT
style set in a symbol element is not inherited by contents.
similarly for fill or stroke
Comment 1 jay 2006-09-10 14:15:44 PDT
Created attachment 10492 [details]
demonstration of stroke being set, but not inherited
Comment 2 Eric Seidel (no email) 2006-09-10 23:31:51 PDT
Ah, I think this is known.
Comment 3 Eric Seidel (no email) 2006-09-12 23:35:44 PDT
I'm not sure how much this has to do with inheritance.

The stroke width is set on the element itself, yet is not respected during the <use>.  <use> is pretty hairy, and pretty broken in WebKit, but I would have thought we would have gotten this part right.  I expect we simply dont' copy the style over correctly.
Comment 4 Rob Buis 2007-01-06 14:43:37 PST

*** This bug has been marked as a duplicate of 12125 ***