RESOLVED FIXED 107910
Coordinated Graphics: Refactor code related to debug border and repaint count.
https://bugs.webkit.org/show_bug.cgi?id=107910
Summary Coordinated Graphics: Refactor code related to debug border and repaint count.
Dongseong Hwang
Reported 2013-01-24 21:30:12 PST
Match drawing debug visuals of Coordinated Graphics to Bug 105787.
Attachments
Patch (21.59 KB, patch)
2013-01-24 21:39 PST, Dongseong Hwang
no flags
Patch (21.59 KB, patch)
2013-01-28 14:07 PST, Dongseong Hwang
no flags
Patch (24.75 KB, patch)
2013-01-28 16:21 PST, Dongseong Hwang
no flags
Patch (24.96 KB, patch)
2013-01-28 16:22 PST, Dongseong Hwang
no flags
Patch (24.74 KB, patch)
2013-01-28 16:44 PST, Dongseong Hwang
no flags
Patch for landing (24.54 KB, patch)
2013-01-28 22:33 PST, Dongseong Hwang
no flags
Patch for landing (24.79 KB, patch)
2013-01-28 22:36 PST, Dongseong Hwang
no flags
Patch for landing (24.54 KB, patch)
2013-01-28 22:40 PST, Dongseong Hwang
no flags
Dongseong Hwang
Comment 1 2013-01-24 21:39:09 PST
Dongseong Hwang
Comment 2 2013-01-24 21:40:56 PST
I did not change WK2 part. See Bug 105787#c54 and Bug 105787#c55
EFL EWS Bot
Comment 3 2013-01-25 01:58:44 PST
Early Warning System Bot
Comment 4 2013-01-25 03:35:52 PST
Dongseong Hwang
Comment 5 2013-01-28 14:07:19 PST
Dongseong Hwang
Comment 6 2013-01-28 14:13:49 PST
This patch was already reviewed by noam in Bug 105787. I separated WK2 part in this bug.
Benjamin Poulain
Comment 7 2013-01-28 14:30:56 PST
Comment on attachment 185059 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=185059&action=review I have nothing against this for WebKit2. Please have No'am review it. > Source/WebKit2/UIProcess/CoordinatedGraphics/CoordinatedBackingStore.cpp:165 > + HashMap<uint32_t, CoordinatedBackingStoreTile>::iterator end = m_tiles.end(); > + for (HashMap<uint32_t, CoordinatedBackingStoreTile>::iterator it = m_tiles.begin(); it != end; ++it) Looks like your hashmap is desperate to get a typedef :) > Source/WebKit2/UIProcess/CoordinatedGraphics/CoordinatedBackingStore.h:74 > + WebCore::FloatRect rect() const { return WebCore::FloatRect(WebCore::FloatPoint::zero(), m_size); } This name seems too generic. I have no idea what is a rect for a backing store.
Dongseong Hwang
Comment 8 2013-01-28 15:06:21 PST
(In reply to comment #7) > (From update of attachment 185059 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=185059&action=review > > I have nothing against this for WebKit2. Please have No'am review it. Thank you for review! I ask noam :) > Looks like your hashmap is desperate to get a typedef :) I'll use typedef! > > Source/WebKit2/UIProcess/CoordinatedGraphics/CoordinatedBackingStore.h:74 > > + WebCore::FloatRect rect() const { return WebCore::FloatRect(WebCore::FloatPoint::zero(), m_size); } > > This name seems too generic. I have no idea what is a rect for a backing store. This method matches to TextureMapperTiledBackingStore::rect(). rect is contents rect of a backing store. noam, is it better to change name? something like contentsRect?
Dongseong Hwang
Comment 9 2013-01-28 16:21:26 PST
Dongseong Hwang
Comment 10 2013-01-28 16:22:24 PST
Dongseong Hwang
Comment 11 2013-01-28 16:44:22 PST
Dongseong Hwang
Comment 12 2013-01-28 16:55:48 PST
noam, benjaminp agreed on this patch. could you review again? :)
Noam Rosenthal
Comment 13 2013-01-28 22:03:42 PST
Comment on attachment 185104 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=185104&action=review > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedGraphicsLayer.cpp:380 > + Line not necessary > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedGraphicsLayer.cpp:390 > + Ditto
Dongseong Hwang
Comment 14 2013-01-28 22:33:00 PST
Created attachment 185157 [details] Patch for landing
Dongseong Hwang
Comment 15 2013-01-28 22:36:34 PST
Created attachment 185160 [details] Patch for landing
Dongseong Hwang
Comment 16 2013-01-28 22:40:40 PST
Created attachment 185161 [details] Patch for landing
WebKit Review Bot
Comment 17 2013-01-28 23:46:29 PST
Comment on attachment 185161 [details] Patch for landing Clearing flags on attachment: 185161 Committed r141065: <http://trac.webkit.org/changeset/141065>
WebKit Review Bot
Comment 18 2013-01-28 23:46:34 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.