Bug 107877 - An [ActiveDOMObject] IDL attribute should be inherited
Summary: An [ActiveDOMObject] IDL attribute should be inherited
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
: 78302 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-24 16:39 PST by Kentaro Hara
Modified: 2013-01-30 00:47 PST (History)
9 users (show)

See Also:


Attachments
Patch (8.70 KB, patch)
2013-01-24 16:40 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff
patch for landing (8.68 KB, patch)
2013-01-27 19:28 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2013-01-24 16:39:14 PST
Now we support IDL attribute inheritance. We can remove [ActiveDOMObject] from subclasses.
Comment 1 Kentaro Hara 2013-01-24 16:40:42 PST
Created attachment 184610 [details]
Patch
Comment 2 Adam Barth 2013-01-24 21:41:44 PST
Comment on attachment 184610 [details]
Patch

Great!
Comment 3 WebKit Review Bot 2013-01-24 21:56:05 PST
Comment on attachment 184610 [details]
Patch

Rejecting attachment 184610 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=gce-cq-03', 'apply-attachment', '--no-update', '--non-interactive', 184610, '--port=chromium-xvfb']" exit_code: 2 cwd: /mnt/git/webkit-commit-queue

Last 500 characters of output:
 Can't create file /tmp/ppbx1fY1 : No space left on device
patch: **** Can't create file /tmp/ppRXYP71 : No space left on device
patch: **** Can't create file /tmp/ppr6beL1 : No space left on device
patch: **** Can't create file /tmp/ppVCdIW1 : No space left on device
patch: **** Can't create file /tmp/pppR4cJ2 : No space left on device

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', '--force', '--reviewer', 'Adam Barth']" exit_code: 2 cwd: /mnt/git/webkit-commit-queue

Full output: http://queues.webkit.org/results/16122106
Comment 4 Kentaro Hara 2013-01-24 21:58:44 PST
I'll cq+ it after the /tmp overflow problem is resolved.
Comment 5 WebKit Review Bot 2013-01-25 17:08:11 PST
Comment on attachment 184610 [details]
Patch

Rejecting attachment 184610 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=gce-cq-01', 'land-attachment', '--force-clean', '--non-interactive', '--parent-command=commit-queue', 184610, '--port=chromium-xvfb']" exit_code: 2 cwd: /mnt/git/webkit-commit-queue

Last 500 characters of output:
mit-queue/Source/WebKit/chromium/third_party/skia/src --revision 7329 --non-interactive --force --accept theirs-conflict --ignore-externals' in '/mnt/git/webkit-commit-queue/Source/WebKit/chromium'
50>At revision 7329.

________ running '/usr/bin/python tools/clang/scripts/update.py --mac-only' in '/mnt/git/webkit-commit-queue/Source/WebKit/chromium'

________ running '/usr/bin/python gyp_webkit' in '/mnt/git/webkit-commit-queue/Source/WebKit/chromium'
Updating webkit projects from gyp files...

Full output: http://queues.webkit.org/results/16114589
Comment 6 Kentaro Hara 2013-01-27 19:28:53 PST
Created attachment 184929 [details]
patch for landing
Comment 7 WebKit Review Bot 2013-01-27 20:07:58 PST
Comment on attachment 184929 [details]
patch for landing

Clearing flags on attachment: 184929

Committed r140938: <http://trac.webkit.org/changeset/140938>
Comment 8 WebKit Review Bot 2013-01-27 20:08:02 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Kentaro Hara 2013-01-30 00:47:14 PST
*** Bug 78302 has been marked as a duplicate of this bug. ***