Bug 107860 - DFG::JITCompiler::getSpeculation() methods are badly named and superfluous
Summary: DFG::JITCompiler::getSpeculation() methods are badly named and superfluous
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on:
Blocks: 106868
  Show dependency treegraph
 
Reported: 2013-01-24 13:57 PST by Filip Pizlo
Modified: 2013-01-24 14:00 PST (History)
7 users (show)

See Also:


Attachments
the patch (2.71 KB, patch)
2013-01-24 13:58 PST, Filip Pizlo
mhahnenberg: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2013-01-24 13:57:38 PST
They should be called getPrediction().  But they're superfluous since it takes less typing to just call Node::prediction() anyway.
Comment 1 Filip Pizlo 2013-01-24 13:58:45 PST
Created attachment 184574 [details]
the patch
Comment 2 Mark Hahnenberg 2013-01-24 13:59:44 PST
Comment on attachment 184574 [details]
the patch

r=me
Comment 3 Filip Pizlo 2013-01-24 14:00:58 PST
Landed in http://trac.webkit.org/changeset/140719