Bug 107741 - [Chromium] Remove unused header files in chromium/public/platform/
Summary: [Chromium] Remove unused header files in chromium/public/platform/
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Pilgrim (Google)
URL:
Keywords:
: 106227 (view as bug list)
Depends on:
Blocks: 82948
  Show dependency treegraph
 
Reported: 2013-01-23 14:46 PST by Mark Pilgrim (Google)
Modified: 2013-01-23 17:50 PST (History)
11 users (show)

See Also:


Attachments
Patch (215.57 KB, patch)
2013-01-23 14:49 PST, Mark Pilgrim (Google)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Pilgrim (Google) 2013-01-23 14:46:30 PST
[Chromium] Remove unused header files in chromium/public/platform/
Comment 1 Mark Pilgrim (Google) 2013-01-23 14:49:08 PST
Created attachment 184317 [details]
Patch
Comment 2 Mark Pilgrim (Google) 2013-01-23 14:49:19 PST
*** Bug 106227 has been marked as a duplicate of this bug. ***
Comment 3 WebKit Review Bot 2013-01-23 14:51:43 PST
Please wait for approval from abarth@webkit.org, dglazkov@chromium.org, fishd@chromium.org, jamesr@chromium.org or tkent@chromium.org before submitting, as this patch contains changes to the Chromium public API. See also https://trac.webkit.org/wiki/ChromiumWebKitAPI.
Comment 4 Mark Pilgrim (Google) 2013-01-23 14:52:00 PST
After 1-1 discussion with fishd, we've decided to abandon the attempt to add Platform/chromium to the dependent_dirs for embedders. All previous patches to that end in Chromium land will be reverted. Header files in WebKit/chromium/public/ will use relative paths to #include header files in Platform/chromium/public/.
Comment 5 James Robinson 2013-01-23 14:54:39 PST
Sorry about giving you the run-around!
Comment 6 Mark Pilgrim (Google) 2013-01-23 14:56:38 PST
It was a good idea that turned out to be more trouble than it was worth.
Comment 7 Tony Chang 2013-01-23 15:58:45 PST
(In reply to comment #4)
> After 1-1 discussion with fishd, we've decided to abandon the attempt to add Platform/chromium to the dependent_dirs for embedders. All previous patches to that end in Chromium land will be reverted. Header files in WebKit/chromium/public/ will use relative paths to #include header files in Platform/chromium/public/.

Should we do the same for #includes in TestRunner/public including header files in Platform/chromium/public?  Then we could remove '../chromium' from the list of include_dirs and direct_dependent_settings in Platform.gyp.
Comment 8 Mark Pilgrim (Google) 2013-01-23 17:37:46 PST
(In reply to comment #7)
> Should we do the same for #includes in TestRunner/public including header files in Platform/chromium/public?  Then we could remove '../chromium' from the list of include_dirs and direct_dependent_settings in Platform.gyp.

I would be happy to do that once this patch lands, if there is consensus.
Comment 9 WebKit Review Bot 2013-01-23 17:50:24 PST
Comment on attachment 184317 [details]
Patch

Clearing flags on attachment: 184317

Committed r140621: <http://trac.webkit.org/changeset/140621>
Comment 10 WebKit Review Bot 2013-01-23 17:50:28 PST
All reviewed patches have been landed.  Closing bug.