Bug 10741 - selecting a select option by typing its value fails
Summary: selecting a select option by typing its value fails
Status: RESOLVED DUPLICATE of bug 9764
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2006-09-05 17:16 PDT by Mark Malone
Modified: 2007-02-23 11:04 PST (History)
3 users (show)

See Also:


Attachments
test case (1.36 KB, text/html)
2006-09-05 17:17 PDT, Mark Malone
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Malone 2006-09-05 17:16:56 PDT
If a user set focus to a select element by tabbing to it then types a known value, the select doesn't set the current value to what was typed.

If the user clicks on the drop down then clicks off, then types types a know value, the correct item is selected.
Comment 1 Mark Malone 2006-09-05 17:17:35 PDT
Created attachment 10408 [details]
test case
Comment 2 Mark Malone 2006-09-05 17:17:48 PDT
rdar://4718187
Comment 3 Alexey Proskuryakov 2006-09-05 21:37:35 PDT
I'm seeing different results in stock Safari and TOT:

Stock Safari: the value changes only after tabbing out from the control. This is native Cocoa behavior, and it feels buggy to me.

TOT: typing has no effect. This matches Carbon, and I used to think that this is expected behavior.
Comment 4 mitz 2006-11-11 10:10:28 PST
Is this different from bug 9764?
Comment 5 Alexey Proskuryakov 2007-02-23 11:04:23 PST
Closing as a duplicate per comment 4.

*** This bug has been marked as a duplicate of 9764 ***