Bug 10733 - Dynamically appending items to ol/ul lists doesn't work in XHTML
Summary: Dynamically appending items to ol/ul lists doesn't work in XHTML
Status: RESOLVED DUPLICATE of bug 8007
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2006-09-04 13:58 PDT by Alexey Proskuryakov
Modified: 2006-10-02 07:34 PDT (History)
1 user (show)

See Also:


Attachments
test case (435 bytes, application/xhtml+xml)
2006-09-04 13:58 PDT, Alexey Proskuryakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-09-04 13:58:37 PDT
For XHTML documents, appending new items produces broken results - the new items all go in one line lacking a list marker.

When examining the resulting document in Inspector, errors are logged to the console:

/Users/ap/WebKit/WebCore/bindings/objc/WebScriptObject.mm:198:[8444]  JavaScript exception:  Null value
Comment 1 Alexey Proskuryakov 2006-09-04 13:58:57 PDT
Created attachment 10394 [details]
test case
Comment 2 DenisBB 2006-10-02 03:37:29 PDT
I had the same problem when I was trying to add with appendChild and createElement (JavaScript) new elemnts to DOM of XHTML valid document (application/xhtml+xml). I enabled DEBUG in Safari (not webkit) and looked at the code of the page. it showed me that if i try to add link to a page it 4example adds this code "<a href="link"/>text</a>". the same thing with paragraph it adds "<p/>text</p>".
So the problem is that it adds to opening tag "/" at the end of it.
Comment 3 mitz 2006-10-02 07:34:20 PDT

*** This bug has been marked as a duplicate of 8007 ***