I think ValueType would be good class name for the containers internal data buffers.
I can eval the actual class name for ValueType but it will gives us nothing new because the same class name is a part of the container class name.
Also this class name may significantly increase the footprint of the binary.
Created attachment 183504 [details]
Created attachment 183620 [details]
Committed r141591: <http://trac.webkit.org/changeset/141591>