Bug 107255 - Add explicit keyword to constructors in platform-specific InspectorClient
Summary: Add explicit keyword to constructors in platform-specific InspectorClient
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-18 03:46 PST by Seokju Kwon
Modified: 2013-01-18 07:44 PST (History)
6 users (show)

See Also:


Attachments
Patch (10.26 KB, patch)
2013-01-18 04:09 PST, Seokju Kwon
no flags Details | Formatted Diff | Diff
Patch (14.38 KB, patch)
2013-01-18 07:17 PST, Seokju Kwon
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Seokju Kwon 2013-01-18 03:46:35 PST
Add explicit keyword to constructors that take exactly one argument
in platform-specific implementation of InspectorClient.
Comment 1 Seokju Kwon 2013-01-18 04:09:15 PST
Created attachment 183424 [details]
Patch
Comment 2 WebKit Review Bot 2013-01-18 04:11:04 PST
Attachment 183424 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit/blackberry/ChangeLog', u'Sou..." exit_code: 1
Source/WebKit/wince/WebCoreSupport/InspectorClientWinCE.h:37:  The parameter name "webView" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:51:  The parameter name "webView" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 2 in 14 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Kentaro Hara 2013-01-18 04:31:14 PST
Comment on attachment 183424 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=183424&action=review

LGMT with nits.

>> Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:51
>> +        explicit InspectorClient(WebKitWebView* webView);
> 
> The parameter name "webView" adds no information, so it should be removed.  [readability/parameter_name] [5]

Nit: Remove it.

> Source/WebKit/mac/WebCoreSupport/WebInspectorClient.h:62
> +    explicit WebInspectorClient(WebView *);

Nit: WebView * => WebView*

>> Source/WebKit/wince/WebCoreSupport/InspectorClientWinCE.h:37
>> +    explicit InspectorClientWinCE(WebView* webView);
> 
> The parameter name "webView" adds no information, so it should be removed.  [readability/parameter_name] [5]

Nit: Remove it.
Comment 4 Seokju Kwon 2013-01-18 07:17:30 PST
Created attachment 183446 [details]
Patch
Comment 5 Seokju Kwon 2013-01-18 07:21:58 PST
Comment on attachment 183446 [details]
Patch

Fix some coding style issues

Source/WebKit/wince/WebCoreSupport/InspectorClientWinCE.h:37:  The parameter name "webView" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:35:  Alphabetical sorting problem.  [build/include_order] [4]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:42:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:51:  The parameter name "webView" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:79:  The parameter name "webInspector" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:79:  The parameter name "inspectorClient" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/gtk/WebCoreSupport/InspectorClientGtk.h:96:  The parameter name "height" adds no information, so it should be removed.  [readability/parameter_name] [5]
Comment 6 WebKit Review Bot 2013-01-18 07:44:50 PST
Comment on attachment 183446 [details]
Patch

Clearing flags on attachment: 183446

Committed r140148: <http://trac.webkit.org/changeset/140148>
Comment 7 WebKit Review Bot 2013-01-18 07:44:55 PST
All reviewed patches have been landed.  Closing bug.