Bug 10715 - REGRESSION: The Organize interface on flickr fails to load images.
Summary: REGRESSION: The Organize interface on flickr fails to load images.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.flickr.com/photos/organize/
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2006-09-03 14:27 PDT by Troy Brandt
Modified: 2007-03-29 11:21 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Troy Brandt 2006-09-03 14:27:34 PDT
I'm not sure what exactly is going on here but when visiting:

http://www.flickr.com/photos/organize/

WebKit fails to load any of your images. This works in Safari 2.0.4 (419.3) just fine, in the nightly the interface appears to fail loading completely. This is fully reproducible for me in WebKit r13302 and r16172.
Comment 1 Nick Poulos 2006-10-24 14:28:33 PDT
I have a similar problem as described. What appears to be the base panels for the interface load, but none of your photos do (and neither does the secondary navigation at top). Furthermore, the primary navigation does not work.
Opening the JavaScript console shows three errors; two in organizr.js.v1.341 and one in findr.js.v1.153, all at line 1 (due to a seeming fear of line breaks on the part of the developers?):

* TypeError: Value undefined (result of expression _ge("tabl_mat_map").mat_set_size) is not object.
* TypeError: Value undefined (result of expression _ge(_31).mat_deactivate) is not object.
* TypeError: Value undefined (result of expression _ge("candy_findr_end").button_disable) is not object.

I don't know whether the failure to load is related to these errors. I don't see any failures to load in the Activity window, and it works for me in Camino.

I'm running 10.4.8 with 2.0.4 (420.+).
Comment 2 Roland Wolters 2007-01-23 15:14:48 PST
The same problem occurs on the KDE platform:
http://bugs.kde.org/show_bug.cgi?id=133125
Also, the flickr guys said they will look into this:
http://www.flickr.com/forums/bugs/31203/
Comment 3 Maciej Stachowiak 2007-01-30 14:56:48 PST
Sounds like a regression. Bumping to P1.
Comment 4 Darin Adler 2007-01-30 22:24:36 PST
<rdar://problem/4965998>
Comment 5 Simon Pride 2007-02-23 17:22:26 PST
Seconded, observed tonight with build as of 2007-02-23.
Comment 6 Matt Lilek 2007-02-23 18:27:51 PST
I tried going though the nightlies with this and it's broken in the oldest nightly available - WebKit-CVS-2005-10-01 03:27:01 GMT.dmg which roughly corresponds to r10690ish.
Comment 7 Darin Adler 2007-03-11 09:36:49 PDT
I tried this today, and organize seems to be working perfectly. The page did reject my browser until I clicked on the link and said "force=1".
Comment 8 Darin Adler 2007-03-11 09:37:47 PDT
This was fixed, probably on the flickr side.
Comment 9 Troy Brandt 2007-03-11 17:16:19 PDT
(In reply to comment #7)
> I tried this today, and organize seems to be working perfectly. The page did
> reject my browser until I clicked on the link and said "force=1".
> 

I'm still encountering the same results from before. I'm using the address:

http://www.flickr.com/photos/organize/?force=1
 
With ToT r20103 and I'm just presented with the empty interface. Is it just me? Also, my browser wasn't rejected, I don't know if that has anything to do with this. Safari 2.0.4 continues to work. 
Comment 10 Darin Adler 2007-03-13 06:44:24 PDT
Oops, the Radar is closed and can't be re-opened, so this goes into the "NeedsRadar" category again.

One difference is that I was testing with new Safari as well as new WebKit, but I'd be surprised if that's the difference.

The photo view worked just fine for me, not sure why.
Comment 11 Nick Poulos 2007-03-13 10:31:37 PDT
I'm using r20136, and I'm still having the same issues; while the organizr interface loads, it is unresponsive and loads none of my pictures.

Appending force=1 to the URL doesn't make a difference for me - the results are the same regardless.
Comment 12 Mark Rowe (bdash) 2007-03-13 16:21:05 PDT
<rdar://problem/5061021>
Comment 13 Kevin McCullough 2007-03-22 12:18:24 PDT
It is an issue that we must use http://www.flickr.com/photos/organize/?force=1 (rdar://problem/5081617), however I do not get any errors on this page and can use all of the functionality with the nightlies, and had other people change on other configurations and we cannot reproduce.
Comment 14 Troy Brandt 2007-03-22 14:11:09 PDT
Just wanted to add my findings here. It looks like Old Skool accounts are subject to this problem and not new ones. I have an old account that still (even in r20387) has this problem. I've moved my account over to the new yahoo login system but that doesn't play into this apparently. Switching to a new account though seems to clear the problem up. 

I'm going to contact flickr support and see if I can get any help from them on this matter. 
Comment 15 Nick Poulos 2007-03-22 19:29:13 PDT
Mr. Brandt seems to be correct - I can reproduce this behavior. Weird!
Comment 16 Troy Brandt 2007-03-29 11:21:20 PDT
(In reply to comment #15)
> Mr. Brandt seems to be correct - I can reproduce this behavior. Weird!
> 

FYI: The organizr is now working for me in WebKit.