Bug 107138 - Make renderer construction take Element where possible
Summary: Make renderer construction take Element where possible
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 107176
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 10:05 PST by Antti Koivisto
Modified: 2013-01-19 06:36 PST (History)
19 users (show)

See Also:


Attachments
patch (91.71 KB, patch)
2013-01-17 11:06 PST, Antti Koivisto
hyatt: review+
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff
patch2 (93.02 KB, patch)
2013-01-18 12:54 PST, Antti Koivisto
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2013-01-17 10:05:32 PST
This requires changing how anonymous renderers are constructed.
Comment 1 Antti Koivisto 2013-01-17 11:06:55 PST
Created attachment 183217 [details]
patch
Comment 2 Dave Hyatt 2013-01-17 11:38:22 PST
Comment on attachment 183217 [details]
patch

r=me
Comment 3 WebKit Review Bot 2013-01-17 11:51:01 PST
Comment on attachment 183217 [details]
patch

Attachment 183217 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/15925698
Comment 4 Antti Koivisto 2013-01-17 12:16:19 PST
http://trac.webkit.org/changeset/140023
Comment 5 Hin-Chung Lam 2013-01-17 13:27:52 PST
This patch seems to failure a number of tests on Lion and Mountain Lion:

http://build.webkit.org/builders/Apple%20Lion%20Release%20WK1%20%28Tests%29/builds/8275
http://build.webkit.org/builders/Apple%20MountainLion%20Release%20WK1%20%28Tests%29/builds/5804

EWS also says these tests are failing on Mac:

Regressions: Unexpected text-only failures (29)
  accessibility/render-counter-text.html [ Failure ]
  editing/selection/5240265.html [ Failure ]
  editing/selection/css-pseudo-element.html [ Failure ]
  editing/selection/focus-crash.html [ Failure ]
  editing/selection/hit-test-anonymous.html [ Failure ]
  editing/selection/undo-crash.html [ Failure ]
  fast/css-generated-content/hover-inline.html [ Failure ]
  fast/dom/Node/mutation-blur.html [ Failure ]
  fast/events/domactivate-sets-underlying-click-event-as-handled.html [ Failure ]
  fast/events/popup-allowed-from-gesture-initiated-form-submit.html [ Failure ]
  fast/events/popup-blocked-from-untrusted-mouse-click.html [ Failure ]
  fast/forms/multiple-form-submission-protection-mouse.html [ Failure ]
  fast/forms/range/slider-delete-while-dragging-thumb.html [ Failure ]
  fast/forms/search-delete-while-cancel-button-clicked.html [ Failure ]
  fast/forms/submit-to-blank-multiple-times.html [ Failure ]
  fast/history/form-submit-in-frame-via-onclick.html [ Failure ]
  fast/history/form-submit-in-frame.html [ Failure ]
  fast/history/gesture-before-onload-form-submit.html [ Failure ]
  fast/history/history_reload.html [ Failure ]
  fast/images/animated-gif-restored-from-bfcache.html [ Failure ]
  fast/loader/javascript-url-in-object.html [ Failure ]
  http/tests/inspector/console-resource-errors.html [ Failure ]
  http/tests/security/mixedContent/redirect-https-to-http-iframe-in-main-frame.html [ Failure ]
  inspector/styles/styles-source-offsets.html [ Failure ]
  media/audio-delete-while-slider-thumb-clicked.html [ Failure ]
  media/media-fullscreen-inline.html [ Failure ]
  platform/mac/accessibility/css-content-attribute.html [ Failure ]
  svg/batik/text/smallFonts.svg [ Failure ]
  svg/dom/SVGScriptElement/script-load-and-error-events.svg [ Failure ]
Comment 6 WebKit Review Bot 2013-01-17 13:57:37 PST
Re-opened since this is blocked by bug 107176
Comment 7 Antti Koivisto 2013-01-18 12:54:46 PST
Created attachment 183532 [details]
patch2

For EWS with a RenderText fix
Comment 8 WebKit Review Bot 2013-01-18 12:57:06 PST
Attachment 183532 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/rendering/RenderText.cpp:139:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Total errors found: 1 in 99 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 9 WebKit Review Bot 2013-01-18 13:38:36 PST
Comment on attachment 183532 [details]
patch2

Attachment 183532 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/15940845
Comment 10 Peter Beverloo (cr-android ews) 2013-01-18 15:27:59 PST
Comment on attachment 183532 [details]
patch2

Attachment 183532 [details] did not pass cr-android-ews (chromium-android):
Output: http://queues.webkit.org/results/15939816
Comment 11 Antti Koivisto 2013-01-19 06:36:47 PST
http://trac.webkit.org/changeset/140244 (with chrome test build fix)