Bug 106821 - [WK2] REGRESSION(r138301): NetworkProcess scheduler never resumes resource loads that were postponed due to connection limit
Summary: [WK2] REGRESSION(r138301): NetworkProcess scheduler never resumes resource lo...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-01-14 13:28 PST by Alexey Proskuryakov
Modified: 2013-01-14 14:53 PST (History)
1 user (show)

See Also:


Attachments
proposed fix (2.01 KB, patch)
2013-01-14 13:29 PST, Alexey Proskuryakov
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2013-01-14 13:28:05 PST
There is an uninitialized variable, and if it happens to be non-0, loading works badly.
Comment 1 Alexey Proskuryakov 2013-01-14 13:29:44 PST
Created attachment 182618 [details]
proposed fix
Comment 2 Brady Eidson 2013-01-14 13:31:44 PST
Comment on attachment 182618 [details]
proposed fix

View in context: https://bugs.webkit.org/attachment.cgi?id=182618&action=review

> Source/WebKit2/ChangeLog:4
> +        NetworkProcess scheduler never resumes resource loads that were postponed
> +        due to connection limit

suspendPendingRequests count actually has nothing to do with the per-host limit.  May as well just say something like "Completely remove the concept of suspending requests from the network process"
Comment 3 Alexey Proskuryakov 2013-01-14 13:32:44 PST
Committed <http://trac.webkit.org/changeset/139655>.
Comment 4 Alexey Proskuryakov 2013-01-14 13:40:26 PST
<rdar://problem/13010102>
Comment 5 Alexey Proskuryakov 2013-01-14 14:53:03 PST
> > Source/WebKit2/ChangeLog:4
> > +        NetworkProcess scheduler never resumes resource loads that were postponed
> > +        due to connection limit
> 
> suspendPendingRequests count actually has nothing to do with the per-host limit.  May as well just say something like "Completely remove the concept of suspending requests from the network process"

The reason why this is related to per-host limit is that only requests that were delayed (due to the limit or to other reasons) were then checked against m_suspendPendingRequestsCount.