Bug 106698 - Builder should not be a valid parameter for stats dashboard
Summary: Builder should not be a valid parameter for stats dashboard
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Julie Parent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-11 14:01 PST by Julie Parent
Modified: 2013-01-11 16:43 PST (History)
3 users (show)

See Also:


Attachments
Patch (2.99 KB, patch)
2013-01-11 14:27 PST, Julie Parent
no flags Details | Formatted Diff | Diff
Patch for landing (2.99 KB, patch)
2013-01-11 15:26 PST, Julie Parent
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Julie Parent 2013-01-11 14:01:55 PST
This dashboard displays results for all builders, so builder is not a valid parameter here, as it is for other dashboards.

Aka, loading http://test-results.appspot.com/dashboards/aggregate_results.html#builder=WebKit%20Win7 should at least print a warning about invalid parameter.
Comment 1 Julie Parent 2013-01-11 14:27:30 PST
Created attachment 182418 [details]
Patch
Comment 2 Dirk Pranke 2013-01-11 14:57:18 PST
Comment on attachment 182418 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=182418&action=review

> Tools/ChangeLog:12
> +        Note that the FIXME in dashboard_base about this was acutally wrong -

nit: "actually".
Comment 3 Julie Parent 2013-01-11 15:26:52 PST
Created attachment 182432 [details]
Patch for landing
Comment 4 WebKit Review Bot 2013-01-11 16:43:12 PST
Comment on attachment 182432 [details]
Patch for landing

Clearing flags on attachment: 182432

Committed r139522: <http://trac.webkit.org/changeset/139522>
Comment 5 WebKit Review Bot 2013-01-11 16:43:15 PST
All reviewed patches have been landed.  Closing bug.