Bug 106584 - Dashboard Cleanup: Do not generate the page if we are about to reload.
Summary: Dashboard Cleanup: Do not generate the page if we are about to reload.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Julie Parent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-10 11:05 PST by Julie Parent
Modified: 2013-01-10 11:53 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.76 KB, patch)
2013-01-10 11:09 PST, Julie Parent
no flags Details | Formatted Diff | Diff
Patch for landing (3.01 KB, patch)
2013-01-10 11:35 PST, Julie Parent
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Julie Parent 2013-01-10 11:05:53 PST
Dashboard Cleanup: Do not generate the page if we are about to reload.
Comment 1 Julie Parent 2013-01-10 11:09:44 PST
Created attachment 182173 [details]
Patch
Comment 2 Dirk Pranke 2013-01-10 11:22:23 PST
Comment on attachment 182173 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=182173&action=review

> Tools/TestResultServer/static-dashboards/dashboard_base.js:-330
> -                return {};

can you add a comment up at line 318 indicating that the function returns whether to generate the page or not? The function name is slightly misleading since it's now parsing parameters *and* telling you whether to generate the page, but I can't think of a better function name that would capture that w/o being awkward.
Comment 3 Ojan Vafai 2013-01-10 11:23:29 PST
Comment on attachment 182173 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=182173&action=review

> Tools/TestResultServer/static-dashboards/dashboard_base.js:353
> +        shouldGeneratePage = handleQueryParameterChange(dashboardSpecificDiffState);

Nit: early return here and you can get rid of the local variable.
Comment 4 Dirk Pranke 2013-01-10 11:24:36 PST
(In reply to comment #3)
> (From update of attachment 182173 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=182173&action=review
> 
> > Tools/TestResultServer/static-dashboards/dashboard_base.js:353
> > +        shouldGeneratePage = handleQueryParameterChange(dashboardSpecificDiffState);
> 
> Nit: early return here and you can get rid of the local variable.

I thought of that too but realized that it's not clear what the true/false indicates, and so a named variable is helpful (cf. my other comment).
Comment 5 Julie Parent 2013-01-10 11:35:22 PST
Created attachment 182179 [details]
Patch for landing
Comment 6 WebKit Review Bot 2013-01-10 11:53:56 PST
Comment on attachment 182179 [details]
Patch for landing

Clearing flags on attachment: 182179

Committed r139348: <http://trac.webkit.org/changeset/139348>
Comment 7 WebKit Review Bot 2013-01-10 11:53:59 PST
All reviewed patches have been landed.  Closing bug.