Bug 106415 - REGRESSION(r139145): Multiple fast/workers tests fail
Summary: REGRESSION(r139145): Multiple fast/workers tests fail
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Unspecified
: P1 Critical
Assignee: Oliver Hunt
URL:
Keywords: InRadar
: 108144 108217 (view as bug list)
Depends on:
Blocks: 79668 98898
  Show dependency treegraph
 
Reported: 2013-01-08 21:23 PST by Stephanie Lewis
Modified: 2015-08-29 21:14 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.48 KB, patch)
2013-01-28 11:20 PST, Oliver Hunt
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stephanie Lewis 2013-01-08 21:23:35 PST
Due to http://trac.webkit.org/projects/webkit/changeset/139145
Failing on Mac WK1 and WK2, Release and Debug, Mountain Lion and Lion.

The tests are timing out waiting for notifyDone and flaky.  Every once in awhile they'll pass.

[1/3] fast/workers/worker-close-more.html failed unexpectedly (text diff)
[2/3] fast/workers/worker-document-leak.html failed unexpectedly (text diff)
[3/3] fast/workers/worker-lifecycle.html failed unexpectedly (text diff)
Comment 1 Stephanie Lewis 2013-01-08 21:32:01 PST
Updated Expectations in http://trac.webkit.org/projects/webkit/changeset/139160
Comment 3 Csaba Osztrogonác 2013-01-08 22:32:14 PST
Similar flakiness on EFL, GTK and Qt. :-/
Comment 4 Csaba Osztrogonác 2013-01-08 22:42:22 PST
I skipped them on Qt - r139164 to paint the bots green.
Please unskip them with the proper fix.

(It is P1/critical bug, because it is a regression and tests fail with timeout)
Comment 5 Alexey Proskuryakov 2013-01-09 10:00:02 PST
<rdar://problem/12981718>
Comment 6 Csaba Osztrogonác 2013-01-13 01:44:24 PST
Are you working on fixing this serious regression?
Comment 7 Csaba Osztrogonác 2013-01-15 02:37:52 PST
ping?
Comment 8 Oliver Hunt 2013-01-15 09:21:05 PST
(In reply to comment #7)
> ping?

Eventually.  I'm side tracked with other more important bugs for a couple of days.

Could you do some analysis yourself?  Maybe you'll find some obvious cause of the problem.

Otherwise causing two layout tests to hang, but not having real world site breakage means that this can wait a few more days.
Comment 9 Csaba Osztrogonác 2013-01-23 16:07:10 PST
I checked this bug, it seems it isn't valid on ToT with Qt 64 bit release.
I have no idea which revision fixed it and don't have time to bisect 1000+
revision. Unfortunately it's hard to reproduce, because these tests passed 
if you ran only fast/workers tests, but failed if you ran all fast tests. (on r139145)
Comment 10 Oliver Hunt 2013-01-23 16:11:58 PST
(In reply to comment #9)
> I checked this bug, it seems it isn't valid on ToT with Qt 64 bit release.
> I have no idea which revision fixed it and don't have time to bisect 1000+
> revision. Unfortunately it's hard to reproduce, because these tests passed 
> if you ran only fast/workers tests, but failed if you ran all fast tests. (on r139145)

Thanks for checking.  I'll look around and see if there's anything obviously stupid happening.  It's possible that this was just a temporary thing before i fixed the massive gc bug i had introduced :-/
Comment 11 Oliver Hunt 2013-01-28 11:20:53 PST
Created attachment 185020 [details]
Patch
Comment 12 Oliver Hunt 2013-01-28 11:21:17 PST
Committed r140981: <http://trac.webkit.org/changeset/140981>
Comment 13 Alexey Proskuryakov 2013-01-28 19:31:45 PST
Comment on attachment 185020 [details]
Patch

Clearing review flag from a landed patch.
Comment 15 Oliver Hunt 2013-01-28 20:56:49 PST
(In reply to comment #14)
> These tests are still failing :( See http://build.webkit.org/results/Apple%20MountainLion%20Release%20WK2%20(Tests)/r141034%20(5309)/results.html

goddammit
Comment 16 Csaba Osztrogonác 2013-01-28 21:41:01 PST
(In reply to comment #14)
> These tests are still failing :( See http://build.webkit.org/results/Apple%20MountainLion%20Release%20WK2%20(Tests)/r141034%20(5309)/results.html

Reopen, because it seems it is still valid bug.
Comment 17 Ryosuke Niwa 2013-01-28 22:04:25 PST
*** Bug 108144 has been marked as a duplicate of this bug. ***
Comment 18 Ryosuke Niwa 2013-01-28 22:05:38 PST
I think we need to add these failing expectations back.
Comment 19 Oliver Hunt 2013-01-29 08:51:39 PST
(In reply to comment #18)
> I think we need to add these failing expectations back.

yup.  this makes no sense.
Comment 20 Ryosuke Niwa 2013-01-29 10:21:05 PST
This bug is causing Mac EWS bots to erroneously reject patches.
Comment 21 Oliver Hunt 2013-01-29 10:22:04 PST
(In reply to comment #20)
> This bug is causing Mac EWS bots to erroneously reject patches.

Sorry, i thought you'd said you were going to revert the patch, i'll be able to do so in half an hour
Comment 22 Oliver Hunt 2013-01-29 10:22:28 PST
(patch being the expectation patch)
Comment 23 Ryosuke Niwa 2013-01-29 10:23:45 PST
(In reply to comment #21)
> (In reply to comment #20)
> > This bug is causing Mac EWS bots to erroneously reject patches.
> 
> Sorry, i thought you'd said you were going to revert the patch, i'll be able to do so in half an hour

Done that in r141133.
Comment 24 Ryosuke Niwa 2013-01-29 10:26:42 PST
In the future, I recommend using

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20webkit.org&tests=fast%2Fworkers%2Fworker-close-more.html%2Cfast%2Fworkers%2Fworker-document-leak.html%2Cfast%2Fworkers%2Fworker-lifecycle.html

It shows historical actual failure / pass status of these tests reported by bots. As you can see, these tests occasionally pass.
Comment 25 Ryosuke Niwa 2013-01-29 13:10:34 PST
*** Bug 108217 has been marked as a duplicate of this bug. ***
Comment 26 Timothy Hatcher 2013-03-29 11:56:24 PDT
These are also failing most of the time on Windows. I marked them as flaky in https://trac.webkit.org/r147232.
Comment 27 Alexey Proskuryakov 2013-09-26 17:02:25 PDT
Still timing out.
Comment 28 Alexey Proskuryakov 2015-08-29 00:21:21 PDT
Looks like r189009 took care of fast/workers/worker-close-more.html

fast/workers/worker-document-leak.html has been passing for a long time now

and fast/workers/worker-lifecycle.html too.