Bug 106230 - media/video-controls-captions.html fails after fixing https://bugs.webkit.org/show_bug.cgi?id=105536
Summary: media/video-controls-captions.html fails after fixing https://bugs.webkit.org...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Victor Carbune
URL:
Keywords: InRadar
: 106433 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-07 10:15 PST by Antoine Quint
Modified: 2013-01-10 09:47 PST (History)
8 users (show)

See Also:


Attachments
Fix (4.55 KB, patch)
2013-01-10 08:58 PST, Victor Carbune
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2013-01-07 10:15:53 PST
The test at media/video-controls-captions.html fails upon fixing the bug at https://bugs.webkit.org/show_bug.cgi?id=105536. Alas, this test appears to be Chrome-specific and I can't diagnose the issue from the bots output.
Comment 1 Radar WebKit Bug Importer 2013-01-07 10:16:03 PST
<rdar://problem/12966324>
Comment 2 Victor Carbune 2013-01-07 12:52:11 PST
I applied your patch from bug 105536 and the test is failing because with the
patch applied the toggling the captions button has no effect anymore (e.g. a user
can't disable track rendering). I didn't look yet in the code for the cause.
Comment 3 Eric Carlson 2013-01-07 14:22:11 PST
(In reply to comment #2)
> I applied your patch from bug 105536 and the test is failing because with the
> patch applied the toggling the captions button has no effect anymore (e.g. a user
> can't disable track rendering). I didn't look yet in the code for the cause.

It fails because clicking the captions button in a port without a captions menu eventually ends up in  HTMLMediaElement::markCaptionAndSubtitleTracksAsUnconfigured, which depends on the code removed from HTMLMediaElement::configureTextTrackGroup by bug 105536 to choose the most appropriate default track.
Comment 4 Silvia Pfeiffer 2013-01-07 14:28:35 PST
OK, I will work on introducing the caption menu for Chrome today.
Comment 5 Victor Carbune 2013-01-10 08:58:29 PST
Created attachment 182151 [details]
Fix
Comment 6 Eric Carlson 2013-01-10 09:22:05 PST
*** Bug 106433 has been marked as a duplicate of this bug. ***
Comment 7 WebKit Review Bot 2013-01-10 09:47:05 PST
Comment on attachment 182151 [details]
Fix

Clearing flags on attachment: 182151

Committed r139326: <http://trac.webkit.org/changeset/139326>
Comment 8 WebKit Review Bot 2013-01-10 09:47:09 PST
All reviewed patches have been landed.  Closing bug.