Bug 106166 - Make WKViews work when layer-backed
Summary: Make WKViews work when layer-backed
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-01-04 20:37 PST by Simon Fraser (smfr)
Modified: 2013-01-07 11:58 PST (History)
16 users (show)

See Also:


Attachments
Patch (6.13 KB, patch)
2013-01-04 20:41 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (fixing other ports) (10.18 KB, patch)
2013-01-07 11:22 PST, Simon Fraser (smfr)
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2013-01-04 20:37:22 PST
Make WKViews work when layer-backed
Comment 1 Simon Fraser (smfr) 2013-01-04 20:41:18 PST
Created attachment 181425 [details]
Patch
Comment 2 Simon Fraser (smfr) 2013-01-04 20:41:49 PST
<rdar://problem/12824569>
Comment 3 Early Warning System Bot 2013-01-04 20:48:02 PST
Comment on attachment 181425 [details]
Patch

Attachment 181425 [details] did not pass qt-wk2-ews (qt):
Output: http://queues.webkit.org/results/15710561
Comment 4 EFL EWS Bot 2013-01-04 20:56:18 PST
Comment on attachment 181425 [details]
Patch

Attachment 181425 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/15703569
Comment 5 Simon Fraser (smfr) 2013-01-07 11:22:51 PST
Created attachment 181537 [details]
Patch (fixing other ports)
Comment 6 WebKit Review Bot 2013-01-07 11:25:12 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 7 Darin Adler 2013-01-07 11:25:48 PST
Comment on attachment 181537 [details]
Patch (fixing other ports)

View in context: https://bugs.webkit.org/attachment.cgi?id=181537&action=review

> Source/WebKit2/UIProcess/PageClient.h:93
> +    // Return rue if scrollView() can copy bits in the view.
> +    virtual bool canScrollView() = 0;

Typo: "rue".

Name "can scroll view" doesn’t seem to be related to whether copying bits is OK. Can we come up with a better name? I think we’ve dealt with this elsewhere.
Comment 8 Simon Fraser (smfr) 2013-01-07 11:30:32 PST
(In reply to comment #7)
> (From update of attachment 181537 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=181537&action=review
> 
> > Source/WebKit2/UIProcess/PageClient.h:93
> > +    // Return rue if scrollView() can copy bits in the view.
> > +    virtual bool canScrollView() = 0;
> 
> Typo: "rue".
> 
> Name "can scroll view" doesn’t seem to be related to whether copying bits is OK. Can we come up with a better name? I think we’ve dealt with this elsewhere.

I was following the naming of scrollView(), which I think is also confusing (in more ways than one!).
Comment 9 Simon Fraser (smfr) 2013-01-07 11:58:28 PST
http://trac.webkit.org/changeset/138973