Bug 10577 - REGRESSION: Password: Add caps lock icon to new password field
Summary: REGRESSION: Password: Add caps lock icon to new password field
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL:
Keywords: InRadar, Regression
: 14963 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-08-25 17:46 PDT by Adele Peterson
Modified: 2007-10-30 14:17 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2006-08-25 17:46:33 PDT
Add caps lock icon to new password field

Maybe this can be done with a background image.  Or maybe we can have the theme draw it over the background.
Comment 1 David Kilzer (:ddkilzer) 2007-08-14 04:56:39 PDT
*** Bug 14963 has been marked as a duplicate of this bug. ***
Comment 2 David Kilzer (:ddkilzer) 2007-08-14 04:57:14 PDT
<rdar://problem/5408845>

Comment 3 Eric Seidel (no email) 2007-10-21 21:05:58 PDT
This isn't very useful to Bugzilla since open source contributers can't really solve this.  Even if we used a background image, we can't add the "capslock image" to webkit svn.  Probably the correct solution is to augment wkDrawBezeledTextFieldCell to know how to draw the capslock image as well.
Comment 4 Adele Peterson 2007-10-22 11:26:50 PDT
i think its fine to leave this in bugzilla.  I have a patch that draws the image w/ CG code in RenderTheme.
Comment 5 Adele Peterson 2007-10-30 14:17:27 PDT
Committed revision 27264.