Bug 10555 - openclipart frontpage lays out wrong
: openclipart frontpage lays out wrong
Status: RESOLVED DUPLICATE of bug 10085
: WebKit
Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P4 Normal
Assigned To:
: http://www.openclipart.org/
: HasReduction
:
:
  Show dependency treegraph
 
Reported: 2006-08-24 23:26 PST by
Modified: 2007-03-31 05:58 PST (History)


Attachments
Screenshot showing the problem (206.44 KB, image/png)
2006-08-24 23:27 PST, Eric Seidel
no flags Details
Reduction (252 bytes, text/html)
2006-08-25 00:37 PST, mitz@webkit.org
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-08-24 23:26:37 PST
openclipart frontpage lays out wrong

the "forward arrow" graphic is on the wrong line.
------- Comment #1 From 2006-08-24 23:27:24 PST -------
Created an attachment (id=10210) [details]
Screenshot showing the problem
------- Comment #2 From 2006-08-25 00:37:11 PST -------
Created an attachment (id=10211) [details]
Reduction

Opera and Safari don't grow the div all the way to the right when it contains a right float. Firefox and IE do.

Specifically with openclipart, they actually try not to rely on the float to make the div stretch, but they have a typo in default.css (missing a semicolon after z-index: 2):

#search {
    position:               absolute;
    left:                   0;
    top:                    100px;
    z-index:                2

    width:                  100%;
    min-width:              700px;

Fixing the typo fixes the layout.
------- Comment #3 From 2006-10-01 02:56:00 PST -------
Filed https://bugs.freedesktop.org/show_bug.cgi?id=8460
------- Comment #4 From 2006-10-13 00:43:32 PST -------
The openclipart.org CSS is fixed now.
------- Comment #5 From 2007-03-31 05:58:48 PST -------
(In reply to comment #4)
> The openclipart.org CSS is fixed now.
> 

The difference in behavior between Firefox and WebKit is tracked by bug 10085.

*** This bug has been marked as a duplicate of 10085 ***