Bug 105457 - Ref test images are upside-down in WebKit2
Summary: Ref test images are upside-down in WebKit2
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL: http://build.webkit.org/results/Apple...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-19 13:20 PST by Simon Fraser (smfr)
Modified: 2013-01-17 16:13 PST (History)
3 users (show)

See Also:


Attachments
Patch (1.62 KB, patch)
2013-01-17 13:31 PST, Simon Fraser (smfr)
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2012-12-19 13:20:27 PST
When showing failure images for ref tests for WK2 tests, the images are flipped (upside-down). This implies that we're comparing upside-down images, which is harmless but wrong.
Comment 1 Zan Dobersek 2012-12-29 11:03:40 PST
This is still occurring on Mac (looking at the builder output), but I can't reproduce it on GTK. Seems as it's Mac-specific.
Comment 2 Simon Fraser (smfr) 2013-01-17 12:55:55 PST
--pixel-test images are also flipped, breaking all pixel tests :(
Comment 3 Simon Fraser (smfr) 2013-01-17 13:31:45 PST
Created attachment 183260 [details]
Patch
Comment 4 Simon Fraser (smfr) 2013-01-17 16:13:15 PST
http://trac.webkit.org/changeset/140067