WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
105359
REGRESSION(
r137607
): PluginDocument loads consume huge amounts of memory
https://bugs.webkit.org/show_bug.cgi?id=105359
Summary
REGRESSION(r137607): PluginDocument loads consume huge amounts of memory
Nate Chapin
Reported
2012-12-18 16:01:45 PST
Original report:
https://code.google.com/p/chromium/issues/detail?id=166374
To reproduce, go to a plugin that loads as a main resource in a chromium canary (e.g.,
http://www.scb.se/statistik/_publikationer/NR0001_2012K02_TI_A28TI1203.pdf
). That 4MB pdf can easily consume multiple GBs of memory. The problem is that CachedRawResource implicitly assumes that, if setShouldBufferData() will be called, it will be called before the load starts. PluginDocument calls it after receiving the first chunk of data, which leaves CachedRawResource in an inconsistent state> It ends up sending the entirety of the data received so far in each callback instead of only the incremental data.
Attachments
patch
(2.77 KB, patch)
2012-12-18 16:06 PST
,
Nate Chapin
no flags
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Nate Chapin
Comment 1
2012-12-18 16:06:53 PST
Created
attachment 180047
[details]
patch
Alexey Proskuryakov
Comment 2
2012-12-19 09:31:09 PST
Comment on
attachment 180047
[details]
patch View in context:
https://bugs.webkit.org/attachment.cgi?id=180047&action=review
> Source/WebCore/ChangeLog:12 > + (WebCore::ResourceLoader::setShouldBufferData): shouldBufferData is an enum, not a boolean, so this is reversed.
It's named as a boolean, so it should be renamed.
Nate Chapin
Comment 3
2012-12-19 09:32:36 PST
(In reply to
comment #2
)
> (From update of
attachment 180047
[details]
) > View in context:
https://bugs.webkit.org/attachment.cgi?id=180047&action=review
> > > Source/WebCore/ChangeLog:12 > > + (WebCore::ResourceLoader::setShouldBufferData): shouldBufferData is an enum, not a boolean, so this is reversed. > > It's named as a boolean, so it should be renamed.
true I'll do that in a separate patch.
WebKit Review Bot
Comment 4
2012-12-19 09:39:55 PST
Comment on
attachment 180047
[details]
patch Clearing flags on attachment: 180047 Committed
r138174
: <
http://trac.webkit.org/changeset/138174
>
WebKit Review Bot
Comment 5
2012-12-19 09:39:59 PST
All reviewed patches have been landed. Closing bug.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug