Bug 104634 - Infinite loop in textPath
Summary: Infinite loop in textPath
Status: RESOLVED DUPLICATE of bug 112078
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-10 23:22 PST by Philip Rogers
Modified: 2015-04-27 15:06 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Rogers 2012-12-10 23:22:05 PST
The following will cause an infinite loop and subsequent crash:

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" id="looper">
  <text>
    <textPath xlink:href="#looper">boop</textPath>
  </text>
</svg>
Comment 1 Said Abou-Hallawa 2015-04-27 15:06:11 PDT
Already fixed in ​https://bugs.webkit.org/show_bug.cgi?id=112078

*** This bug has been marked as a duplicate of bug 112078 ***