Bug 10453 - Nested quotes rendered incorrectly
: Nested quotes rendered incorrectly
Status: RESOLVED DUPLICATE of bug 3234
: WebKit
Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-08-16 23:37 PST by
Modified: 2006-08-17 02:49 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-08-16 23:37:46 PST
HTML includes a quote element, <q>, for displaying localized and stylized quotation marks. When this element is nested, the rendering of the marks changes from double-quotes to single-quotes (by default). The spec on this is here:

http://www.w3.org/TR/html4/struct/text.html#h-9.2.2.1

And an example can be found on section 2 of this page:

http://www.seomoz.org/blogdetail.php?ID=1282

Note that WebKit incorrectly renders the inner marks as double-quotes. Confirmed on the r15924 build.
------- Comment #1 From 2006-08-17 02:49:35 PST -------
Bug 3234 states that the inner quotes are rendered as single hash marks (apostrophes) - that's not what I'm seeing. Anyway, that bug is basically about the same issue.

*** This bug has been marked as a duplicate of 3234 ***